Ask Your Question
0

"1" is not supported api version example values "1" or "2" in glance

asked 2015-01-17 02:26:36 -0500

sumeshkollam gravatar image

glance image-create --name="cirros" --disk-format=qcow2 --container-format=bare --is-public=true --progress < cirros-0.3.2-x86_64-disk.img The following are the error during the glance installation phase in - image service in openstack When I am trying to upload the image into the image service.

The following are the specification on my systems. openstack on ubuntu 14.04 LTS server 64 bit version Two nodes controller node and compute node Controller node hardware configuration is Xeon intel processor with 8 GB RAM and 500 GB hard disk OpenStack version is 2.16-1 imagenfile: cirros-0.3.2-x86_64-disk.img

The following are the active lines in my /etc/glance/glance-api.conf file bind_host=0.0.0.0 bind_port=9262 log_file=/var/log/glance/api.log backing=4096

connection=mysql://glance:amma123@controller/glance [keystone] auth_uri=http://controller:5000 auth_host=controller auth_port=35357 admin_tenant_name=http admin_user=glance admin_password=amma123

[paste_deploy] flavor=keystone

edit retag flag offensive close merge delete

Comments

are you able to run:

glance --os-image-api-version 2 image-list

also tell glance --version

yatin gravatar imageyatin ( 2015-01-17 14:13:20 -0500 )edit

hi yatin thank u for ur response when i am trying to run the glance --os-image-api-version 2 image-list
command the system gives the error as given below No module named netifaces and my glance version is 0.15.0

sumeshkollam gravatar imagesumeshkollam ( 2015-01-19 00:38:34 -0500 )edit

I also executed the command dpkg | grep glance and the last two lines are li python-glance 1:0.12.0-0ubuntu1 all openstack image registry and devlivery service - python library li python-glanceclient 1:0.12.0-ubuntu1 all client library for openstack glance

sumeshkollam gravatar imagesumeshkollam ( 2015-01-19 01:12:47 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-23 09:59:31 -0500

cloudsbyday gravatar image

You don't have the netifaces installed since you're getting that error.

Fix this by installing it:

sudo pip install netifaces

Then verify:

glance --os-image-api-version 2 image-list

Should get back:

+-----+-------+
| ID   | Name|
+-----+-------+

Then rerun your glance image-create

edit flag offensive delete link more

Comments

thank you for your valuable comments. Now I can upload the image at glance

sumesh s gravatar imagesumesh s ( 2015-02-26 08:45:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-01-17 02:26:36 -0500

Seen: 1,024 times

Last updated: Jan 23 '15