Ask Your Question
0

Why does RDO Packstack fail?

asked 2015-01-17 02:04:43 -0600

Morgan Ross Egging gravatar image

updated 2015-01-17 03:13:02 -0600

https://openstack.redhat.com/Neutron_with_existing_external_network (https://openstack.redhat.com/Neutron_...)

I have made over 100 attempts to install Openstack On CentOS using Packstack on bare metal compatible hardware, in many hardware and network environments. All have failed. Why?

[root@localhost ~]# service network start Starting network (via systemctl): Job for network.service failed. See 'systemctl status network.service' and 'journalctl -xn' for details. [FAILED]

localhost.localdomain systemd[1]: Failed to start LSB: Bring up/down networking.

I have every log from every attempt. 100's of megabytes. Don't ask for a log, instead question : "WHY" does packstack fail.

edit retag flag offensive close merge delete

Comments

Is net-tools installed ?

dbaxps gravatar imagedbaxps ( 2015-01-17 02:57:52 -0600 )edit

https://openstack.redhat.com/forum/discussion/892/problem-with-disable-networkmanager/p1 (https://openstack.redhat.com/forum/di...) I tried it, no effect. I tried everything on that page.

Morgan Ross Egging gravatar imageMorgan Ross Egging ( 2015-01-17 03:08:43 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-17 05:09:35 -0600

dbaxps gravatar image

updated 2015-01-17 05:13:08 -0600

Did you try CentOS 7 Workstation with "Development tools" && "Virtualization" ?
I never saw error you talking about. When I am done with Juno install && Editing ifcfg-br-ex, ifcfg-enp2s0 :-

chkconfig network on
systemctl stop NetworkManager
systemctl disable NetworkManager
service network restart

Syntax of ifcfg-* files is like on old CentOS 6.X ( DEVICE="enp2s0" not NAME="enp2s0")
It might happen that reboot required to start network service on Fedoras 21,20, but not on CentOS 7
Here it works right away.

[root@juno1 network-scripts(keystone_admin)]# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="192.168.1.127"
NETMASK="255.255.255.0"
DNS1="83.221.202.254"
BROADCAST="192.168.1.255"
GATEWAY="192.168.1.1"
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

[root@juno1 network-scripts(keystone_admin)]# cat ifcfg-enp2s0
DEVICE="enp2s0"
# HWADDR=00:22:15:63:E4:E2
ONBOOT="yes"
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex
NM_CONTROLLED=no
IPV6INIT=no
edit flag offensive delete link more

Comments

what is CentOS 7 Workstation with "Development tools" && "Virtualization"?

Morgan Ross Egging gravatar imageMorgan Ross Egging ( 2015-01-17 09:17:30 -0600 )edit

Download ISO from http://isoredirect.centos.org/centos/...
During install select Workstation and mentioned groups for install.

dbaxps gravatar imagedbaxps ( 2015-01-17 09:42:00 -0600 )edit

I tried again with those 2 checkboxes, it installed a desktop and has no effect on error.

Morgan Ross Egging gravatar imageMorgan Ross Egging ( 2015-01-21 16:45:50 -0600 )edit
0

answered 2015-01-17 09:10:09 -0600

Morgan Ross Egging gravatar image

Thank you for your answer, I will try it when I get home. Thank you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-17 02:04:43 -0600

Seen: 864 times

Last updated: Jan 17 '15