Ask Your Question
1

Can't ssh into my VM. Getting "Server refused our key" error with PuTTY.

asked 2015-01-15 10:18:38 -0500

jfockler gravatar image

updated 2015-01-15 19:41:28 -0500

9lives gravatar image

I used the dashboard to create a router, a network, then created a Ubuntu 14.04 VM. I have tried creating the VM with "Create keypair" and also with "Import keypair" and pasting the public key. I associated a floating IP and I can ping the IP from a DOS cmd prompt. When I try to access the VM using PuTTY I get the "Server refused our key" error. I checked the log file in the Horizon dashboard and I see cloud-init and sshd are started. With PuTTY I get "PuTTY Fatal Error" with "Disconnected: No supported authentication methods available (server sent: publickey)"

I must be missing something very basic during my VM creation. What do I need to do to be able to access my VM?

Here is the log file from Horizon:

 * Starting NTP server ntpd       [80G [74G[ OK ]
 * Stopping CPU interrupts balancing daemon[74G[ OK ]
open-vm-tools: not starting as this is not a VMware VM
 * Starting automatic crash report generation[74G[ OK ]
landscape-client is not configured, please run landscape-config.
 * Restoring resolver state...       [80G [74G[ OK ]
touch: cannot touch '/var/lock/subsys/local': No such file or directory
 * Stopping System V runlevel compatibility[74G[ OK ]
Generating locales...
  en_US.UTF-8... up-to-date
Generation complete.

Ubuntu 14.04 LTS vm01 ttyS0

vm01 login: Cloud-init v. 0.7.5 running 'modules:final' at Thu, 15 Jan 2015 16:04:20 +0000. Up 9.62 seconds.

vm01 login: Cloud-init v. 0.7.5 running 'modules:final' at Thu, 15 Jan 2015 16:04:20 +0000. Up 9.62 seconds.
ci-info: +++++++++++++++Authorized keys from /root/.ssh/authorized_keys for user root+++++++++++++++
ci-info: +---------+-------------------------------------------------+---------+-------------------+
ci-info: | Keytype |                Fingerprint (md5)                | Options |      Comment      |
ci-info: +---------+-------------------------------------------------+---------+-------------------+
ci-info: | ssh-rsa | xx:xx:xx:xx:xx:xx:xx:74:7f:b1:6e:ef:ac:14:xx:xx |    -    | Generated by Nova |
ci-info: +---------+-------------------------------------------------+---------+-------------------+
ec2: 
 :
 :
Cloud-init v. 0.7.5 finished at Thu, 15 Jan 2015 16:04:20 +0000. Datasource DataSourceConfigDriveNet [net,ver=2][source=/dev/sr0].  Up 9.70 seconds
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-15 17:35:32 -0500

capsali gravatar image

Does the vm get metadata from openstack?

Also when you created the ubuntu vm did u select the keypair that you created from the access and security tab?

If so then when you connect with putty you must take the .pem keyfile and transform it using puttygen into a putty recognisible format (.ppk). Then you load it into putty and connect to the ubuntu vm. The default username is ubuntu.

If this doesn't work then the metadata service isn't working. Check if the service is running and view the logs .

In my case, where i have 2 controller nodes and 3 compute nodes using neutron dvr, if i created a vm it wouldnt fetch the metadata from the controller nodes untill i enabled the metadata service on the compute nodes aswell.

edit flag offensive delete link more
0

answered 2015-01-16 12:21:21 -0500

jfockler gravatar image

updated 2015-01-16 17:02:11 -0500

Thank you. I don't see any metadata service, no cloud-init, and no sshd. My log file shows only a question mark "?" I restarted the instance and still see only a "?" in the log file.

I am contacting our Openstack support team. I can ping the Public IP from my Windows DOS prompt. I am using PuTTY on my Windows 7, 64-bit image. I copied the public key directly from Puttygen and pasted it into the "Import keypair" option in the Horizon dashboard. I used a PuTTY profile that I tested that uses the same keypair and renamed it and used the new VM's public IP (which I can ping). Now I get the PuTTY prompt for a password:

"username@ip_address's password:"

I will contact our support team and ask them to check on their side

UPDATE I used the dashboard to create a new keypair, used Puttygen to convert it to a .ppk then I used the nova command line to create a VM and was able to successfully login. I am spinning up a new VM in the dashboard and using the new key to see if my problem was my existing key or if it is the Horizon Dashboard.

edit flag offensive delete link more

Comments

It turns out in this particular zone I have to create a key pair or import a key pair then ssh in as "root". The ID I used to create the VM and the keypair would not work.I had to use the nova command line to create the VM. For some reason any VM I spun up from the Dashboard just would not work.

jfockler gravatar imagejfockler ( 2015-01-23 18:53:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-01-15 10:18:38 -0500

Seen: 3,883 times

Last updated: Jan 16 '15