Ask Your Question
1

Neutron network can't connected with the OVH server

asked 2015-01-15 07:44:51 -0500

anonymous user

Anonymous

updated 2015-01-15 15:21:32 -0500

Hey, I installed OpenStack juno in a hosted server at OVH. and all went well except that outside the installation of neutron I have a problem with the connection to the server via ssh. I use a single interface, and I followed this tutorail to get a good functioning of external and internal network:

ovs-vsctl add-br br-eth0
ovs-vsctl add-port br-eth0 eth0
ifconfig br-eth0 <@ IP of server > up
ifconfig br-eth0 hw ether xx:xx:xx:xx:xx:
route add default gw "@ GATEWAY-IP" br-eth0
ip link set br-eth0 promisc on
ip link add proxy-br-eth1 type veth peer name eth1-br-proxy
ip link add proxy-br-ex type veth peer name ex-br-proxy
ovs-vsctl add-br br-eth1
ovs-vsctl add-br br-ex
ovs-vsctl add-port br-eth1 eth1-br-proxy
ovs-vsctl add-port br-ex ex-br-proxy
ovs-vsctl add-port br-eth0 proxy-br-eth1
ovs-vsctl add-port br-eth0 proxy-br-ex
ip link set eth1-br-proxy up promisc on
ip link set ex-br-proxy up promisc on
ip link set proxy-br-eth1 up promisc on
ip link set proxy-br-ex up promisc on

and I edit the /etc/network/interfaces as followings:

auto eth0
iface eth0 inet manual


auto br-eth0
iface br-eth0 inet static
        address 192.168.0.x
        network 192.168.0.0
        netmask 255.255.255.0
        broadcast 192.168.0.255
        gateway 192.168.0.x
        dns-nameservers 8.8.8.8 8.8.4.4

but when I restart the server, I can not connect to the server via ssh. And the service maintenance of OVH inform me that the server is in rescue mode. anyone have a solution for this problem ?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-01-31 22:14:18 -0500

noplacelike127 gravatar image

This helped me solve this same issue on my OVH server: http://dohuyhoang.github.io/openstack...

Essentially, you need to spoof the outgoing MAC address from your virtual router.

edit flag offensive delete link more

Comments

@noplacelike127, how you applied config to create bridge? I'm trying a lot but I always lose connection after try to create bridge

Joubert RedRat gravatar imageJoubert RedRat ( 2015-03-30 09:38:31 -0500 )edit
0

answered 2015-03-30 09:39:21 -0500

Joubert RedRat gravatar image

I found this script, but I don't know how to use.

https://github.com/mangelajo/ovh-ebta...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-01-15 07:44:51 -0500

Seen: 1,308 times

Last updated: Mar 30 '15