Ask Your Question
0

Testing Juno inside Icehouse

asked 2015-01-15 06:05:15 -0500

Openstackuser2013 gravatar image

I have working Icehouse environment and I'd like to do some basic testing with Juno by installing it on virtual machines that are on my Icehouse cloud. (Both host and guest OSs are Ubuntu 14.04.)

I had no problem installing Juno until it came time to create bridge br-ex. After adding the bridge the virtual machine loses network connectivity. I suspect that my problem is related to this part from installation guide:

If you choose to install on VMs, make sure your hypervisor permits promiscuous mode and disables MAC address filtering on the external network.

My hypervisor is KVM. How do I permit promiscuous mode and disable MAC address filtering on Openstack?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-15 06:14:43 -0500

dbaxps gravatar image

Below is part of an example file of /etc/network/interface:

auto eth0
iface eth0 inet manual
up ifconfig $IFACE 192.168.1.100 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down
edit flag offensive delete link more

Comments

I use similar configuration that works with physical machines but not with these virtual machines:

auto eth1
iface eth1 inet manual 
up ip address add 0/0 dev $IFACE
up ip link set $IFACE up 
up ifconfig $IFACE promisc
up ifconfig $IFACE multicast
...
Openstackuser2013 gravatar imageOpenstackuser2013 ( 2015-01-15 06:50:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-15 06:05:15 -0500

Seen: 289 times

Last updated: Jan 15 '15