Ask Your Question

Glance-api configure with rbd not able to start

asked 2015-01-15 00:25:26 -0500

senyapsudah gravatar image

updated 2015-01-15 02:14:30 -0500

i have configure glance to use rbd using Ceph Guide, however, i found out after i add the lines for glance inside glance-api configuration and restart . glance api service would not able to start. try to dig inside glance api log and what i can only see is below:

DEBUG glance_store.driver [-] Late loading location class glance_store._drivers.rbd.StoreLocation get_store_location_class /usr/lib/python2.7/dist-packages/glance_store/

is there any place that could debug this.? i have already enable debug inside config file but not much output comeout. please help.

after i run glance-api --debug i got below output.

ERROR: Store for scheme file not found

i believe this is the cause my glance-api would not able to start.

any way to solve this?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2015-01-15 02:26:28 -0500

senyapsudah gravatar image

The issue resolved after i change the default_store = file to default_store = rbd inside /etc/glance/glance-api.conf and restart glance.

edit flag offensive delete link more

answered 2015-07-27 05:05:49 -0500

mingda gravatar image (

updated and deprecated options in Juno for OpenStack Image Service

[default] default_store (Deprecated Option) [glance_store] default_store (New Option)

Therefore, if param "default_store = rbd" is only set in default section, glance service will fail to start.

throw ERROR: Store for scheme file not found

the way to solve this problem is putting the default_store in glance_store section & restart glance service

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-01-15 00:25:26 -0500

Seen: 2,108 times

Last updated: Jul 27 '15