Ask Your Question
0

Adding another NIC to a Centos7 Node [closed]

asked 2015-01-14 14:40:12 -0500

Campos gravatar image

updated 2015-01-14 14:41:24 -0500

Hey there,

I'm trying to install a Two-Node cloud, using CentOS7 and RDO. I installed CentOS7 using a Minimal install, and I'm having trouble installing the drivers for the second NIC.

The machine recognizes the hardware. When i put 'lspci -vv | grep Ethernet", it returns:

  • 0f:00.0 Ethernet controller: VIA Technologies, Inc. VT6105/VT6106S [Rhine-III] (rev 86)
  • 3f:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5761 Gigabit Ethernet PCIe (rev 10)

In which the Broadcom is the onboard network. But when I try ifconfig -a, or ip link show, it only shows the onboard NIC. I've been looking around and it seems on a minimal install, CentOS doesn't have all the drivers. Any idea what should I do?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Campos
close date 2015-01-16 11:57:18.305293

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-14 14:54:44 -0500

dbaxps gravatar image

updated 2015-01-14 15:05:17 -0500

I see 2 options:-

 1. Use first NIC Broadcom as endpoint for VXLAN (GRE) tunnel , because it's not going into production.
 2. Googling with intend to find Linux driver ( source code ) for Ethernet controller: VIA Technologies, build && install loadable driver on CentOS 7
 3. Purchase RTL8139 (the best price) or RTL 8169 and plug into the box. Zerro problems with CentOS 7.
edit flag offensive delete link more

Comments

i actually found the driver, and the installation guide within is this: http://ftp.dlink.ru/pub/Adapter/DFE-5...

But I'm stuck on step 5 on the Installation. "Compile the driver source files and it will generate rhinefet.o" How do I do that?

Campos gravatar imageCampos ( 2015-01-14 14:58:35 -0500 )edit

Decompress folder in may contain executable a kind of autogenerate to create Makefile or may contain Makefile itself:-

$ make
$ make install

You have excellent link , try make && make install

dbaxps gravatar imagedbaxps ( 2015-01-14 15:11:20 -0500 )edit

Just run before build yum groupinstall "C Development Tools and Libraries", double check with yum grouplist the group's name on CentOS 7 .

dbaxps gravatar imagedbaxps ( 2015-01-14 15:20:15 -0500 )edit

I just bought another NIC and it worked. Thanks for the help, though.

Campos gravatar imageCampos ( 2015-01-16 11:56:50 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-14 14:40:12 -0500

Seen: 742 times

Last updated: Jan 14 '15