Swift Account HEAD failed 400 Bad Request [closed]

asked 2015-01-14 05:10:52 -0600

Turki gravatar image

updated 2015-01-14 14:35:26 -0600

smaffulli gravatar image

Hi all,

We installed swift by following the documentation provided from openstack "http://docs.openstack.org/icehouse/install-guide/install/yum/content/before-you-begin-swift-install.html" , we did every step and we double check the configuration of the server.

Our setup consists of two servers, proxy server & storage node. When we try # swift stat it give us the following:

"Account HEAD failed: http://swift-proxy:8080/v1/AUTH_ea167f32a5d948ed98e0c5f5ba61db4a 400 Bad Request"

We searched for this error but we couldn't find any solution.

Here are the configuration of the proxy server: /etc/swift/proxy-server.conf

bind_port = 8080
user = swift

pipeline = healthcheck cache  authtoken keystoneauth  proxy-server

use = egg:swift#proxy
allow_account_management = true
account_autocreate = true

use = egg:swift#keystoneauth
operator_roles = Member,admin,swiftoperator,swift

paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

# Delaying the auth decision is required to support token-less
# usage for anonymous referrers ('.r:*').
delay_auth_decision = true
signing_dir = /tmp/keystone-signing

# auth_* settings refer to the Keystone server
auth_protocol = http
auth_host = controller
auth_port = 35357
auth_uri = http://controller:35357/

# the service tenant and swift username and password created in Keystone
admin_tenant_name = service
admin_user = swift
admin_password = *******

use = egg:swift#memcache
cache = swift.cache
include_service_catalog = False

use = egg:swift#catch_errors

use = egg:swift#healthcheck

and the configuration for /etc/swift/account-server.conf in the Storage node:


bind_ip =
bind_port = 6002
workers = 2

pipeline = account-server

use = egg:swift#account




and the configuration for /etc/swift/container-server.conf in the Storage node:


bind_ip =
bind_port = 6001
workers = 2

pipeline = container-server

use = egg:swift#container





and the configuration for /etc/swift/object-server.conf in the Storage node:


bind_ip =
bind_port = 6000
workers = 3

pipeline = object-server

use = egg:swift#object




We would really appreciate if you can help us with this issue.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by smaffulli
close date 2015-01-14 14:38:15.966661


smaffulli gravatar imagesmaffulli ( 2015-01-14 14:38:12 -0600 )edit