How to disable neutron and re-enable nova-network?

asked 2015-01-09 06:34:11 -0600

gnychis gravatar image

updated 2015-01-09 09:20:52 -0600

I would like to disable neutron and go back to using nova-network. I traced backwards through the Nuetron install guide, removing certain packages and changing nova.cof to remove the [neutron] block and use this instead:

network_api_class = nova.network.api.API
security_group_api = nova
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_manager = nova.network.manager.FlatDHCPManager
network_size = 254
allow_same_net_traffic = False
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_network_bridge = br100
flat_interface = eth0
public_interface = eth0

I restarted all of my services, but when I try to use Horizon I get a "Something went wrong!" server error. Checking the Apache logs, it's still trying to connect to Neutron:

[pid 9051:tid 140694248339200] ConnectionFailed: Connection to neutron failed: Maximum attempts reached

Is there something I am missing to disable neutron? I removed the database, the user, and the service.

Here are my services and endpoints:

gnychis@src-server1:~$ keystone endpoint-list
+----------------------------------+-----------+------------------------------------------+------------------------------------------+------------------------------------------+----------------------------------+
|                id                |   region  |                publicurl                 |               internalurl                |                 adminurl                 |            service_id            |
+----------------------------------+-----------+------------------------------------------+------------------------------------------+------------------------------------------+----------------------------------+
| 7276be80a8e54b7f992fc0a8bb57a3b4 | regionOne |         http://172.16.0.10:9292          |         http://172.16.0.10:9292          |         http://172.16.0.10:9292          | 3d703e71c33a4fc4b9806ee4ead93538 |
| 9691c40fc14d4a6d8177d1624be97826 | regionOne |       http://172.16.0.10:5000/v2.0       |       http://172.16.0.10:5000/v2.0       |      http://172.16.0.10:35357/v2.0       | 5c44b98d31ac48319069f6bbea072072 |
| 9c9269a6847b453cb0830351e5d1531c | regionOne | http://172.16.0.10:8774/v2/%(tenant_id)s | http://172.16.0.10:8774/v2/%(tenant_id)s | http://172.16.0.10:8774/v2/%(tenant_id)s | 6693e44b64244c948b2b111c1e845dea |
| d2dffccb0fcb460ea2b046120634e48f | regionOne |        http://127.0.0.1:5000/v2.0        |        http://127.0.0.1:5000/v2.0        |       http://127.0.0.1:35357/v2.0        | 5c44b98d31ac48319069f6bbea072072 |
+----------------------------------+-----------+------------------------------------------+------------------------------------------+------------------------------------------+----------------------------------+
gnychis@src-server1:~$ keystone service-list
+----------------------------------+----------+----------+--------------------------------+
|                id                |   name   |   type   |          description           |
+----------------------------------+----------+----------+--------------------------------+
| 3d703e71c33a4fc4b9806ee4ead93538 |  glance  |  image   | Soroco OpenStack Image Service |
| 5c44b98d31ac48319069f6bbea072072 | keystone | identity |       OpenStack Identity       |
| 6693e44b64244c948b2b111c1e845dea |   nova   | compute  |    Soroco OpenStack Compute    |
+----------------------------------+----------+----------+--------------------------------+
gnychis@src-server1:~$ nova service-list
+------------------+-----------------+----------+----------+-------+----------------------------+-----------------+
| Binary           | Host            | Zone     | Status   | State | Updated_at                 | Disabled Reason |
+------------------+-----------------+----------+----------+-------+----------------------------+-----------------+
| nova-compute     | Soroco-Compute1 | nova     | enabled  | up    | 2015-01-09T15:19:48.000000 | -               |
| nova-network     | Soroco-Compute1 | internal | enabled  | up    | 2015-01-09T15:19:48.000000 | -               |
| nova-conductor   | src-server1     | internal | enabled  | up    | 2015-01-09T15:19:48.000000 | -               |
| nova-scheduler   | src-server1     | internal | enabled  | up    | 2015-01-09T15:19:51.000000 | -               |
| nova-consoleauth | src-server1     | internal | enabled  | up    | 2015-01-09T15:19:51.000000 | -               |
| nova-cert        | src-server1     | internal | enabled  | up    | 2015-01-09T15:19:51.000000 | -               |
| nova-compute     | src-server1     | nova     | disabled | down  | 2015-01-06T21:01:13.000000 | -               |
| nova-network     | src-server1     | internal | enabled  | up    | 2015-01-09T15:19:48.000000 | -               |
+------------------+-----------------+----------+----------+-------+----------------------------+-----------------+
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-09 07:30:19 -0600

Gauvain Pocentek gravatar image

If the neutron service still exists in the keystone catalog, horizon will try to use it. Have you removed the neutron endpoints and service from the keystone catalog?

edit flag offensive delete link more

Comments

Just added the outpoint of my service list and endpoint list. I'm pretty sure I removed neutron from my services, but I'm not sure about the endpoint? Could you double check what I added to my post?

gnychis gravatar imagegnychis ( 2015-01-09 09:21:39 -0600 )edit

I don't see neutron configurations in the output you provided. So the problem comes from elsewhere but I don't see what it could be.

Gauvain Pocentek gravatar imageGauvain Pocentek ( 2015-01-12 01:06:38 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-01-09 06:34:11 -0600

Seen: 692 times

Last updated: Jan 09 '15