Ask Your Question
0

Ceilometer install fail

asked 2013-10-08 20:18:29 -0500

fandikurnia gravatar image

Hi all,

I am trying to install ceilometer on our infra, but it's a easy step and found many error. My error :

[root@controller-2 ~]# yum list openstack-ceilometer*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Available Packages
openstack-ceilometer-api.noarch              2013.1.3-1.el6         epel-openstack-grizzly
openstack-ceilometer-central.noarch          2013.1.3-1.el6         epel-openstack-grizzly
openstack-ceilometer-collector.noarch        2013.1.3-1.el6         epel-openstack-grizzly
openstack-ceilometer-common.noarch           2013.1.3-1.el6         epel-openstack-grizzly
openstack-ceilometer-compute.noarch          2013.1.3-1.el6         epel-openstack-grizzly
[root@controller-2 ~]# yum install openstack-ceilometer-*
 Finished Dependency Resolution
Error: Package: python-pecan-0.2.1-5.el6.noarch (epel-openstack-grizzly)
           Requires: python-simplegeneric >= 0.8
Error: Package: openstack-ceilometer-api-2013.1.3-1.el6.noarch (epel-openstack-grizzly)
           Requires: python-flask
Error: Package: openstack-ceilometer-collector-2013.1.3-1.el6.noarch (epel-openstack-grizzly)
           Requires: pymongo
Error: Package: openstack-ceilometer-api-2013.1.3-1.el6.noarch (epel-openstack-grizzly)
           Requires: pymongo
Error: Package: python-wsme-0.5b2-1.el6.noarch (epel-openstack-grizzly)
           Requires: python-simplegeneric
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
1:python-keystoneclient-0.2.3-7.el6.noarch has missing requires of python-webob

Hope someone can share how to solved this. I will update as soon if i can find and solve this probelm. Thanks

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-10-08 23:12:09 -0500

fandikurnia gravatar image

updated 2013-10-08 23:13:49 -0500

Ok done, I am find some repo to do this solving my problem today, Here is my repo list :

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.biz.net.id
 * epel: mirror.rndc.or.id
 * extras: mirrors.hostemo.com
 * rpmforge: mirror-fpt-telecom.fpt.net
 * updates: centos.biz.net.id
repo id                                                                            repo name                                                                                             status
10gen                                                                              10gen Repository                                                                                              105
base                                                                               CentOS-6 - Base                                                                                             6,381
ceph                                                                               Ceph packages for x86_64                                                                                       69
ceph-noarch                                                                        Ceph noarch packages                                                                                           11
*epel                                                                              Extra Packages for Enterprise Linux 6 - x86_64                                                              9,784
epel-openstack-grizzly                                                             OpenStack Grizzly Repository for EPEL 6                                                                       362
extras                                                                             CentOS-6 - Extras                                                                                              13
nailgun                                                                            Nailgun                                                                                                     1,090
rpmforge                                                                           RHEL 6 - RPMforge.net - dag                                                                                 4,597
updates                                                                            CentOS-6 - Updates                                                                                          1,336
repolist: 23,748

then try to install python-flask without any complain with python-sphinx

yum install python-flask-0.9-5.el6.noarch

And then install openstack-ceilometer

yum install *openstack-ceilometer*

Regards

Fandi Kurnia

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-10-08 20:18:29 -0500

Seen: 558 times

Last updated: Oct 08 '13