Ask Your Question
1

DevStack: ContextualVersionConflict between decorator 3.3.2 and 3.4.0 (cinder-manage)

asked 2015-01-08 12:11:48 -0600

Ian Y. Choi gravatar image

Hello. Today, I tried to install DevStack Icehouse release on Ubuntu 12.04.5 in my VirtualBox.

I used my own localrc configuration file ( http://goo.gl/OeOGqL ) and retrieved DevStack stable/icehouse branch.

However, I have experienced ContextualVersionConflict on decorator 3.3.2 and 3.4.0 after executing ./stack.sh and DevStack is executing cinder-manage. I am copying & pasting error codes for my stack.sh.log:

2015-01-08 16:50:53.474 | + /usr/local/bin/cinder-manage db sync
2015-01-08 16:50:53.627 | Traceback (most recent call last):
2015-01-08 16:50:53.627 |   File "/usr/local/bin/cinder-manage", line 4, in <module>
2015-01-08 16:50:53.627 |     __import__('pkg_resources').require('cinder==2014.1.4.dev37')
2015-01-08 16:50:53.627 |   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3018, in <module>
2015-01-08 16:50:53.627 |     working_set = WorkingSet._build_master()
2015-01-08 16:50:53.627 |   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 614, in _build_master
2015-01-08 16:50:53.628 |     return cls._build_from_requirements(__requires__)
2015-01-08 16:50:53.628 |   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 627, in _build_from_requirements
2015-01-08 16:50:53.628 |     dists = ws.resolve(reqs, Environment())
2015-01-08 16:50:53.628 |   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 810, in resolve
2015-01-08 16:50:53.628 |     raise VersionConflict(dist, req).with_context(dependent_req)
2015-01-08 16:50:53.628 | pkg_resources.ContextualVersionConflict: (decorator 3.3.2 (/usr/lib/python2.7/dist-packages), Requirement.parse('decorator>=3.4.0'), set(['networkx']))
2015-01-08 16:50:53.635 | + exit_trap
2015-01-08 16:50:53.635 | + local r=1
2015-01-08 16:50:53.635 | ++ jobs -p
2015-01-08 16:50:53.636 | + jobs=
2015-01-08 16:50:53.638 | + [[ -n '' ]]
2015-01-08 16:50:53.638 | + exit 1

Please see the full log: https://gist.githubusercontent.com/ianychoi/58a5785effdaa96ca605/raw/c29f212c2b9b1a39028a9219e0c8bd38fa16aee7/stack.sh.log_error_20150108 (https://gist.githubusercontent.com/ia...)

But when I installed DevStack Icehouse release about six months ago, it successfully installed without any problems. Fortunately, I also the full log for installing without any problems: https://gist.githubusercontent.com/ianychoi/58a5785effdaa96ca605/raw/14a857b7a5cdb1e73eddc94fdbc8cbe45b9d488a/stack.sh.log_okay_20140611 (https://gist.githubusercontent.com/ia...)

And, I have found two contrasting facts:

1) The global requirements for decorator was already 3.4.0 about 11 months ago. (URL: https://github.com/openstack/requirements/commit/7a57027f6a0737bb7a31e19cf20259cec6443cfe (https://github.com/openstack/requirem...) ) Note that it is the log for stable/icehouse branch.

2) The latest python-decorator package for Ubuntu 12.04 is still 3.3.2 : https://launchpad.net/ubuntu/precise/+package/python-decorator (https://launchpad.net/ubuntu/precise/...)

For me, it is somewhat curious because icehouse release needs decorator 3.4.0, as OpenStack global requirement says, but Ubuntu 12.04 uses python-decorator 3.3.2. I installed DevStack icehouse release successfully on Ubuntu 12.04.4 about six months ago.

In my opinion, a few codes on somewhere were changed to make constraint on decorator version as 3.4.0, but now I can not find where ... (more)

edit retag flag offensive close merge delete

Comments

I got the same issue as you did and fixed it by upgrading python-decorator to 3.4.0 prior to the DevStack Icehouse install, by simply running:

easy_install decorator==3.4.0
gboissiere gravatar imagegboissiere ( 2015-02-06 15:32:53 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-09 03:09:27 -0600

fifieldt gravatar image

Hi,

I'd recommend lodging a bug for this at https://bugs.launchpad.net/devstack and asking on the dev mailing list: https://wiki.openstack.org/wiki/Maili...

python-decorator will come from pypi, rather than ubuntu packages i.e.

sudo pip install python-decorator

( https://pypi.python.org/pypi/decorator - version 3.4 is present here)

but this should be automatically done by devstack install, as it is in the requirements, as you mention.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-08 12:09:29 -0600

Seen: 2,227 times

Last updated: Jan 09 '15