Ask Your Question

Account Quota Issue with swift

asked 2015-01-08 11:02:24 -0600

ebyenjoys gravatar image


I have a working cluster of swift in openstack icehoue version. I am trying to enable account quota to my accounts and I have enabled it one of following account as on the screenshot.image description

I have set the Meta Quota-Bytes 10000 and in the stat command the quota has been enabled.

I tried to upload a file which exceeds the quota size. But unfortunately it got uploaded. It is Illustrated on the below screenshot.

image description.

I have enabled the container-quotas filter under proxy-server.conf as follows.

use = egg:swift#container_quotas

Kindly help me to sort out this.

Kind Regards,

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2015-01-09 03:15:58 -0600

fifieldt gravatar image

updated 2015-01-09 03:16:11 -0600


As you want to use account-level quotas, you also need to ensure that account-quotas is in your proxy server pipeline:

In: etc/swift/proxy-server.conf

pipeline = catch_errors healthcheck proxy-logging cache slo ratelimit tempauth container-quotas account-quotas proxy-logging proxy-server

use = egg:swift#account_quotas
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-01-08 11:02:24 -0600

Seen: 224 times

Last updated: Jan 09 '15