Ask Your Question
1

Ceilometer : Not able to get Keystone metrics

asked 2015-01-08 02:10:38 -0500

takahashi gravatar image

updated 2015-01-09 01:33:00 -0500

9lives gravatar image

I cannot get any keystone metrics value by Ceilometer CLI as below. I really appreciate your insight.

[root@node-17 ]# ceilometer sample-list -m identity.authenticate.success -q 'resource_id=0fefb385f2f6498a8e4dc95134fdeca1'
+-------------+------+------+--------+------+-----------+
| Resource ID | Name | Type | Volume | Unit | Timestamp |
+-------------+------+------+--------+------+-----------+
+-------------+------+------+--------+------+-----------+

Thanks in advance.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-01-09 00:32:18 -0500

You need to enable keystone to send notifications.

In ceilometer.conf enable control exchange for keystone.

http_control_exchanges=keystone

In keystone.conf enable keystone to talk to your message bus (rabbit mq config below).

rabbit_host=localhost

# The RabbitMQ broker port where a single node is used.
# (integer value)
rabbit_port=5672

# The RabbitMQ userid. (string value)
rabbit_userid=guest

# The RabbitMQ password. (string value)
rabbit_password=guest

# Driver or drivers to handle sending notifications. (multi
# valued)
notification_driver=keystone.openstack.common.notifier.rpc_notifier

# AMQP topic used for OpenStack notifications. (list value)
# Deprecated group/name - [rpc_notifier2]/topics
notification_topics=notifications

Restart ceilometer services and keystone.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-08 02:10:38 -0500

Seen: 232 times

Last updated: Jan 09 '15