Ask Your Question
1

Cannot install Devstack - permission denied

asked 2015-01-07 04:14:11 -0500

eldadd gravatar image

updated 2015-09-29 12:41:09 -0500

smaffulli gravatar image

Hey! I'm trying to install devstack butt I keep getting:

'/run/user/1000/gvfs': Permission denied, after I run ./stack.sh

I followed the instructions from the All-in-one installetion guide from this site and everithing seemed to work fine..

this is what I get in the end after running the ./stack.sh command:

./stack.sh:753:install_infra
/home/stack/devstack/lib/infra:33:git_clone
/home/stack/devstack/functions-common:606:git_timed
/home/stack/devstack/functions-common:672:die
[ERROR] /home/stack/devstack/functions-common:672 git call failed: [git clone git://git.openstack.org/openstack/requirements.git /opt/stack/requirements]
Error on exit
World dumping... see ./worlddump-2015-01-07-094022.txt for details
df: '/run/user/1000/gvfs': Permission denied

thank you for your help.

Cannot install openstack enviroment Please help!

edit retag flag offensive close merge delete

Comments

1

can you do the git clone manually git clone git://git.openstack.org/openstack/requirements.git /opt/stack/requirements?

9lives gravatar image9lives ( 2015-01-07 08:05:06 -0500 )edit

Adding this as a comment rather than an answer because it solves the same error but is unrelated to gvfs:

If you get a 'permission denied' error having to do with a file in the .cache directory, this directory may have been created as root, so a chown -R stack /home/stack/.cache should work.

Atiaxi gravatar imageAtiaxi ( 2017-03-14 13:17:56 -0500 )edit

7 answers

Sort by ยป oldest newest most voted
2

answered 2015-01-07 08:05:30 -0500

try the following steps.

  1. you shouldn't be a root user
  2. chown -R <username> devstack    ex: chown -R stack devstack
    3. chmod 770 devstack
    4. cd devstack
    5. ./clean.sh
    6. ./stack.sh
    
edit flag offensive delete link more

Comments

1

the above steps removes the lock from devstack folder.

PradeepNaik gravatar imagePradeepNaik ( 2015-01-07 08:07:09 -0500 )edit

thank you for your help!

this line fixed the hole thing: sed -i 's/git:/https:/g' stackrc

now everithing is running as it should.

eldadd gravatar imageeldadd ( 2015-01-14 05:08:59 -0500 )edit

Not working

Maestropandy gravatar imageMaestropandy ( 2016-06-29 02:06:51 -0500 )edit
2

answered 2015-01-14 04:20:53 -0500

eldadd gravatar image

updated 2015-01-14 05:08:23 -0500

thank you for your help!

this line fixed the hole thing: sed -i 's/git:/https:/g' stackrc

now everithing is running as it should.

edit flag offensive delete link more

Comments

are you behind any proxy server when running ./stack.sh?if you do, the http_proxy env variable should be set.

9lives gravatar image9lives ( 2015-01-14 04:58:56 -0500 )edit
1

answered 2015-09-29 09:58:01 -0500

updated 2015-10-14 07:20:22 -0500

I was having the same error. I resolved by starting from scratch and be extremely careful on the following steps:

  1. Create the stack user

    adduser stack

  2. Give permissions

    apt-get install sudo -y || yum install -y sudo echo "stack ALL=(ALL) NOPASSWD: ALL" >> /etc/sudoers

  3. Logout from current user and login back as stack user

  4. Install git

    sudo apt-get install git -y || sudo yum install -y git

  5. Download devstack

    git clone https://git.openstack.org/openstack-dev/devstack

  6. Enter the directory by cd devstack

  7. Run ./stack.sh

The point is that if you do one of the above steps (even git clone!) with a user different from stack it will give problems with permissions.

edit flag offensive delete link more
0

answered 2015-01-07 07:32:43 -0500

make sure your are not doing it a root user, but a stack user

edit flag offensive delete link more
0

answered 2015-01-14 05:23:24 -0500

9lives gravatar image

updated 2015-01-14 05:24:55 -0500

if the git protocol not working, probably you are behind the proxy, therefore change to https:// should work, instead of change in stackrc the best practice is change the GIT_BASE in local.conf like this

...
GIT_BASE=https://git.openstack.org  or
# use github
GIT_BASE=https://github.com
...

Hope that helps!

Vic

edit flag offensive delete link more
0

answered 2016-06-29 02:15:00 -0500

If the issue persists after

  • running user as non-root (as per devstack)
  • changed "sed -i 's/git:/https:/g' stackrc"
  • chown -R <--username--> devstack

Try this by u-mounting gvfs as

sudo umount /run/usr/1000/gvfs

Because If you are getting the permission and other details for gvfs as per the following

d?????????? ? ? ? ? ? gvfs then just unmount your gvfs using the following command. Your issue will get resolve after following this process.

umount ~/gvfs(umount /run/user/112/gvfs in my case). GVFS (GNOME Virtual File System) is the virtual file system for the GNOME desktop, which allows users easy access to remote data via SFTP, FTP, WebDAV, SMB, and local data via udev integration so you do not need to afraid while unmounting this.

edit flag offensive delete link more
0

answered 2014-03-17 13:15:02 -0500

Permission issue, can you go to /devstack and touch a file to see what happens ? $touch test ? for example? are you logged in correctly ? as kevin from the path above ?

edit flag offensive delete link more

Comments

thanks Bill! solved the issue after editing the the permissions to the stack user!

Kevin.TK gravatar imageKevin.TK ( 2014-03-17 13:30:41 -0500 )edit

I am facing the same problem. Please share how did you edit the permissions to the stack user?

fhussain gravatar imagefhussain ( 2015-09-15 01:24:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-07 04:14:11 -0500

Seen: 15,218 times

Last updated: Jun 29 '16