Connection to neutron failed: Maximum attempts reached

asked 2015-01-07 02:38:50 -0500

djepnguyen gravatar image

updated 2015-01-07 02:42:20 -0500

Dear all , im trying to deploy my first openstack. my server1 will be installed all components. server1 is virtual machine with eth0( bridge with client to access the interner IP:10.51.177.106/24) and eth1 is host-only for private internet. all my previous thing are OK when i install and configure neutron. my neutrou configuration is below. please noted that i replaced 10.10.10.2 as below guide to my IP: 10.51.177.106

Remove all the lines from /etc/neutron/neutron.conf and add the following lines
[DEFAULT]
core_plugin = ml2
notification_driver=neutron.openstack.common.notifier.rpc_notifier
verbose=True
rabbit_host=10.10.10.2
rpc_backend=neutron.openstack.common.rpc.impl_kombu
service_plugins=router
allow_overlapping_ips=True
auth_strategy=keystone
neutron_metadata_proxy_shared_secret=openstack
service_neutron_metadata_proxy=True
notify_nova_on_port_data_changes=True
notify_nova_on_port_status_changes=True
nova_admin_auth_url=http://10.10.10.2:35357/v2.0
nova_admin_tenant_id=service
nova_url=http://10.10.10.2:8774/v2
nova_admin_username=nova
nova_admin_password=nova
[keystone_authtoken]
auth_host = 10.10.10.2
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = neutron
admin_password = neutron
signing_dir = $state_path/keystone-signing
rpc_backend = neutron.openstack.common.rpc.impl_kombu
rabbit_host = 10.10.10.2
rabbit_port = 5672
notify_nova_on_port_status_changes = True
notify_nova_on_port_data_changes = True
nova_url = http://10.10.10.2:8774
nova_admin_username = nova
nova_admin_tenant_id =
nova_admin_password = nova
nova_admin_auth_url = http://10.10.10.2:35357/v2.0
[database]
connection = mysql://neutrondbadmin:neutronsecret@10.10.10.2/neutron
[agent]
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
Open /etc/neutron/plugins/ml2/ml2_conf.ini and make the following changes
[ml2]
type_drivers=flat,vlan
tenant_network_types=vlan,flat
mechanism_drivers=openvswitch
[ml2_type_flat]
flat_networks=External
[ml2_type_vlan]
network_vlan_ranges=Intnet1:100:200
[ml2_type_gre]
[ml2_type_vxlan]
[securitygroup]
firewall_driver=neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group=True
[ovs]
bridge_mappings=External:br-ex,Intnet1:br-eth1
We have created two physical networks one as a flat network and the other as a vlan network with vlan ranging from 100 to 200.
We have mapped External network to br-ex and Intnet1 to br-eth1.Now Create bridges
ovs-vsctl add-br br-int
ovs-vsctl add-br br-eth1
ovs-vsctl add-br br-ex
ovs-vsctl add-port br-eth1 eth1
ovs-vsctl add-port br-ex eth2
Edit /etc/neutron/metadata_agent.ini to look like this
[DEFAULT]
auth_url = http://10.10.10.2:5000/v2.0
auth_region = RegionOne
admin_tenant_name = service
admin_user = neutron
admin_password = neutron
metadata_proxy_shared_secret = openstack
Edit /etc/neutron/dhcp_agent.ini to look like this
OpenStack Compute Starter Guide 27
[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
dhcp_driver = neutron.agent.linux.dhcp.Dnsmasq
use_namespaces = True
Edit /etc/neutron/l3_agent.ini to look like this
[DEFAULT]
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
use_namespaces = True
Restart all Neutron services
service neutron-server restart; service neutron-plugin-openvswitch-agent restart;service  -
neutron-metadata-agent restart; service neutron-dhcp-agent restart; service neutron-l3-  -
agent restart

after i try the command : neutron agent-list the error as title will be showed. here the result when i type IP ADDR SHOW :

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2 ...
(more)
edit retag flag offensive close merge delete

Comments

did you search before post your question? there are a lot of similar questions you can find the answers in the end.

9lives gravatar image9lives ( 2015-01-07 02:54:20 -0500 )edit

thanks for you comment. i searched but they are not same my question. each other have a diffirent model and i have to explain more clearly for easily troubleshooting. regards !

djepnguyen gravatar imagedjepnguyen ( 2015-01-07 03:13:14 -0500 )edit

Neutron service has failed to start. The q-svc.log should give you the actual cause of the error behind this message. Verify that.

sripriya gravatar imagesripriya ( 2015-01-07 12:06:03 -0500 )edit