How to configure the external wireless network on /etc/network/interfaces compute node

asked 2015-01-05 11:01:56 -0600

LightMan gravatar image

I am trying to configure the external network parameters on the compute node but I have a problem below is my configuration details in the file /etc/network/interfaces. For the external network interface I have

auto wlan0

iface wlan0 inet manual

up ip link set dev $IFACE up

down ip link set dev $IFACE down

what is wrong with the above external wireless network settings? Please help as soon as possible.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-01-05 11:12:38 -0600

Poonam Agarwal gravatar image

https://help.ubuntu.com/community/WifiDocs/WiFiHowTo (https://help.ubuntu.com/community/Wif...)

This link has your answer!

Adding it to /etc/network/interfaces /etc/network/interfaces is the file where your network interfaces are defined, eth0 being the standard wired interface. To make the wireless network come up when you start your computer put # in front of 'auto eth0' (to stop it automatically starting) and add something like the following lines.

sudo nano -w /etc/network/interfaces

auto wlan0 iface wlan0 inet dhcp wireless-essid MYNETWOTK wireless-key FEFEFEFEFE wireless-channel 11 wireless-mode managed

edit flag offensive delete link more

Comments

Thank you for your swift reply. I wanted both the wireless and wired networks to be active at the same time.How do you that without commenting the auto eth0

LightMan gravatar imageLightMan ( 2015-01-05 11:24:00 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-05 11:01:56 -0600

Seen: 531 times

Last updated: Jan 05 '15