Verify Create initial networks fail

asked 2015-01-05 01:35:25 -0600

DelightD gravatar image

Sorry for my poor english. My OpenStack enviroment is three entity computers one for Controller node , one for Network node(for neutron), last one for compute node. I follow "OpenStack Installation Guide for Ubuntu 14.04-Juno" to build three node architecture when I work at Chap 6. , all network function install on compute, network and controller node is fine , but when I follow guide setup on "Create initial networks" at verify step , I failed , I can not ping the external network to Tenant network

anyone can help me with this problem??

below is my network node config

eth0 for Instance Tunnel IP , eth1 for Management IP , eth2 for External IP

network@network-desktop:~$ ifconfig
br-ex     Link encap:Ethernet  HWaddr 04:1e:64:fc:cb:05  
      inet6 addr: fe80::5492:eff:fe4a:2690/64 Scope:Link
      UP BROADCAST RUNNING  MTU:1500  Metric:1
      RX packets:11 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
br-int    Link encap:Ethernet  HWaddr 9e:c3:a8:1f:1d:46  
      inet6 addr: fe80::4c03:f7ff:fe57:1c7d/64 Scope:Link
      UP BROADCAST RUNNING  MTU:1500  Metric:1
      RX packets:22 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:1780 (1.7 KB)  TX bytes:648 (648.0 B)
br-tun    Link encap:Ethernet  HWaddr c6:95:6b:c3:d6:41  
      inet6 addr: fe80::e473:cfff:fe34:eaf3/64 Scope:Link
      UP BROADCAST RUNNING  MTU:1500  Metric:1
      RX packets:1 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:90 (90.0 B)  TX bytes:648 (648.0 B)
eth0      Link encap:Ethernet  HWaddr 00:25:22:b4:87:f9  
      inet addr:10.0.1.21  Bcast:10.0.1.255  Mask:255.255.255.0
      inet6 addr: fe80::225:22ff:feb4:87f9/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:9 errors:0 dropped:0 overruns:0 frame:0
      TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:762 (762.0 B)  TX bytes:9969 (9.9 KB)
eth1      Link encap:Ethernet  HWaddr 00:60:6e:b1:6e:0d  
      inet addr:10.0.0.21  Bcast:10.0.0.255  Mask:255.255.255.0
      inet6 addr: fe80::260:6eff:feb1:6e0d/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:16399 errors:0 dropped:6861 overruns:0 frame:0
      TX packets:15316 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:921178 (921.1 KB)  TX bytes:3339235 (3.3 MB)
eth2      Link encap:Ethernet  HWaddr 04:1e:64:fc:cb:05  
      inet6 addr: fe80::61e:64ff:fefc:cb05/64 Scope:Link
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 ...
(more)
edit retag flag offensive close merge delete

Comments

Hi. Please verify the output of the command "ip netns list".

It should show an entry like qrouter-<routeruuid>

If not,specify br-ex in Network node's l3 agent conf file "/etc/neutron/l3_agent.ini" as below:

external_network_bridge = br-ex

and restart neutron-l3-agent

teju gravatar imageteju ( 2015-01-06 02:10:28 -0600 )edit

network@network-desktop:~$ ip netns list

qrouter-e38b2ea3-49d9-4623-a3cc-f9871cc1d9f7
qdhcp-675dd2d9-b850-46be-a88b-a7e56495c743

hi, teju this is my ip netns list result so , my config is good? or something wrong?

DelightD gravatar imageDelightD ( 2015-01-07 03:52:10 -0600 )edit

Did you solve your problem?

Tenma gravatar imageTenma ( 2015-05-27 18:25:20 -0600 )edit