Ask Your Question
1

Compute node: "Error contacting glance server"

asked 2015-01-05 00:35:33 -0500

gnychis gravatar image

I am having difficulty deploying an instance, as something seems to be misconfigured on my compute node. Through Dashboard, I create a new instance however I can never connect to it and it seems to be dead. By looking at nova-compute log on my compute node, I see the request come in but the compute node fails to contact the glance server:

AUDIT nova.compute.manager [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] Starting instance...
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] Attempting claim: memory 4096 MB, disk 40 GB, VCPUs 2
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] Total memory: 32070 MB, used: 512.00 MB
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] memory limit: 48105.00 MB, free: 47593.00 MB
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] Total disk: 188 GB, used: 0.00 GB
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] disk limit not specified, defaulting to unlimited
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] Total CPUs: 12 VCPUs, used: 0.00 VCPUs
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] CPUs limit not specified, defaulting to unlimited
AUDIT nova.compute.claims [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] Claim successful
INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server on 172.16.0.10:5672
INFO nova.virt.libvirt.driver [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] [instance: 31fd0aad-b900-4eda-a6ca-6d3d61e9cc56] Creating image

ERROR nova.image.glance [req-6c0851f9-d2e0-4cc6-95a3-e72dd465bc17 fd2397b348fb4ca3b307f414d53f9b6a 44363eba77ca42a9a1bbf22d7fb882f9] Error contacting glance server '172.16.1.1:9292' for 'data', retrying.
TRACE nova.image.glance Traceback (most recent call last):
TRACE nova.image.glance   File "/usr/lib/python2.7/dist-packages/nova/image/glance.py", line 209, in call
...

The odd thing is that I do not know why it's trying to contact the glance server at 172.16.1.1. That is the IP address of the compute node itself. It should instead be trying to contact 172.16.0.10 which is my controller.

Here are statuses of services:

root@Soroco-Compute1:~# nova-manage service list
Binary           Host                                 Zone             Status     State Updated_At
nova-cert        src-server1                          internal         enabled    :-)   2015-01-05 06:32:21
nova-consoleauth src-server1                          internal         enabled    :-)   2015-01-05 06:32:21
nova-scheduler   src-server1                          internal         enabled    :-)   2015-01-05 06:32:21
nova-conductor   src-server1                          internal         enabled    :-)   2015-01-05 06:32:19
nova-network     src-server1                          internal         enabled    :-)   2015-01-05 06:32:19
nova-compute     Soroco-Compute1                      nova             enabled    :-)   2015-01-05 06:32:18
nova-compute     src-server1                          nova             enabled    :-)   2015-01-05 06:32:16

On my compute node, I have the glance host set to 172.16.0.10 (my controller):

[glance]
host = 172.16.0.10

Does anyone know what could be wrong? I'm pretty positive my keystone_authtoken is setup properly. It's what I've used on other nodes.

edit retag flag offensive close merge delete

Comments

what did the grep -iE '^#|^$' /etc/glance-api.conf say in your controller node?

9lives gravatar image9lives ( 2015-01-05 00:58:02 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
2

answered 2015-01-05 07:21:03 -0500

Bipin gravatar image

updated 2015-01-05 07:21:41 -0500

Please make sure the following value in your compute node /etc/nova/nova.conf

[DEFAULT]

glance_host = controller #Here it assumes your glance host is controller node, if not change accordingly.

After that change the openstack-nova-compute service. You will be good.

edit flag offensive delete link more

Comments

Thanks, that worked! The guide didn't state this: http://docs.openstack.org/juno/instal...

gnychis gravatar imagegnychis ( 2015-01-05 09:45:19 -0500 )edit
0

answered 2015-01-05 02:29:54 -0500

9lives gravatar image

Per the juno version of configuration guide to specify the glance-api server host in /etc/glance/glance-api.conf should use this one

# Address to bind the API server
bind_host = 0.0.0.0

# Port the bind the API server to
bind_port = 9292

In nova.conf for compute node should use this one

# GLANCE
[glance]
api_servers=192.168.206.130:9292

Please check the above two configuration files (/etc/glance/glance-api.conf and /etc/nova/nova.conf)

BTW: if there are no api_servers defined , it will use the default one which is ,$myip is the ip address of your compute node.

#(StrOpt) Default glance hostname or IP address
host = $my_ip

This might be the root cause of your original issue.

Hope that helps!

Vic

edit flag offensive delete link more
0

answered 2015-01-05 01:54:28 -0500

gparaskevas gravatar image

updated 2015-01-05 01:55:42 -0500

Do you use cinder as well? If you use cinder check the glance host setting in cinder.conf on your compute nodes. Point it to your controller like this: glance_host=domain or ip of your controller and also glance server

edit flag offensive delete link more
0

answered 2015-01-05 02:00:33 -0500

I dont think using

[glance] host=someip

Is valid.

glance_host=glance_ip

Is what the directive you need to use.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-05 00:35:33 -0500

Seen: 1,044 times

Last updated: Jan 05 '15