Ask Your Question
0

Running keystone user-list throws error Could not find user, keystone. (HTTP 401)

asked 2013-10-07 23:49:16 -0600

balaji gravatar image

Running keystone user-list throws error Could not find user, keystone. (HTTP 401) installed on ubuntu 12.04

Can somebody please help in resolving this

How to configure the initial authentication setup in the keystone

have already run keystone manage db_sync mysql> use keystone; Reading table information for completion of table and column names You can turn off this feature to get a quicker startup with -A

Database changed mysql> show tables; +------------------------+ | Tables_in_keystone | +------------------------+ | credential | | domain | | endpoint | | group | | group_domain_metadata | | group_project_metadata | | migrate_version | | policy | | project | | role | | service | | token | | trust | | trust_role | | user | | user_domain_metadata | | user_group_membership | | user_project_metadata | +------------------------+ 18 rows in set (0.00 sec)

mysql> describe user -> ; +--------------------+--------------+------+-----+---------+-------+ | Field | Type | Null | Key | Default | Extra | +--------------------+--------------+------+-----+---------+-------+ | id | varchar(64) | NO | PRI | NULL | | | name | varchar(255) | NO | | NULL | | | extra | text | YES | | NULL | | | password | varchar(128) | YES | | NULL | | | enabled | tinyint(1) | YES | | NULL | | | domain_id | varchar(64) | NO | MUL | NULL | | | default_project_id | varchar(64) | YES | | NULL | | +--------------------+--------------+------+-----+---------+-------+ 7 rows in set (0.01 sec)

mysql>

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-10-08 04:36:29 -0600

Cloudie gravatar image

Make an openrc file like this

export OS_NO_CACHE=1 export OS_TENANT_NAME=admin

export OS_TENANT_ID=*********

export OS_USERNAME=admin

export OS_PASSWORD=***

export OS_AUTH_URL="http://192.168..:5000/v2.0/"

name it sth like creds or credentials

then source this file from terminal ....like

$source credentials

try running ur command then hope this will help :)

edit flag offensive delete link more

Comments

thanks a lot I tried but i am not sure what to ginve in the password. so added the below line in hte keystone.conf and still getting the error root@aiqranade:/tmp/images# keystone user-list Unable to communicate with identity service: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Not Authorized"}}. (HTTP 401) root@aiqranade:/tmp/images# and i tried by giving an token getting the below error root@aiqranade:/tmp/images# keystone user-list Expecting an endpoint provided via either --os-endpoint or env[OS_SERVICE_ENDPOINT] root@aiqranade:/tmp/images# keystone user-list [auth] methods = password,token password = keystone.auth.plugins.password.Password token = keystone.auth.plugins.token.Token [filter:debug] paste.filter_factory = keystone.common.wsgi:Debug.factory [filter:token_auth] paste.filter_factory = keystone.middleware:TokenAuthMiddleware.factory auth_token = 012345SECRET99TOKEN012345 [filter:authtoken] paste.fi

balaji gravatar imagebalaji ( 2013-10-08 05:06:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-10-07 23:49:16 -0600

Seen: 2,013 times

Last updated: Oct 08 '13