Ask Your Question
0

Puppet error using ODI

asked 2015-01-04 12:21:02 -0500

phillw gravatar image

updated 2015-01-05 14:41:55 -0500

mpetason gravatar image

I'm following https://openstack.redhat.com/Quickstart and RHEL7 and after starting the

packstack --allinone

All goes well until this point:

Copying Puppet modules and manifests                 [ DONE ]
Applying 127.0.0.1_prescript.pp
127.0.0.1_prescript.pp:                           [ ERROR ]       
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 127.0.0.1_prescript.pp
Error: Could not start Service[auditd]: Execution of '/usr/bin/systemctl start auditd' returned 1: Job for auditd.service failed. See 'systemctl status auditd.service' and 'journalctl -xn' for details.
You will find full trace in log /var/tmp/packstack/20150104-125915-uszj1C/manifests/127.0.0.1_prescript.pp.log
Please check log file /var/tmp/packstack/20150104-125915-uszj1C/openstack-setup.log for more information

Additional information: * A new answerfile was created in: /root/packstack-answers-20150104-125915.txt * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components. * File /root/keystonerc_admin has been created on OpenStack client host 127.0.0.1. To use the command line tools you need to source the file. * To access the OpenStack Dashboard browse to http://127.0.0.1/dashboard . Please, find your login credentials stored in the keystonerc_admin in your home directory. * To use Nagios, browse to http://127.0.0.1/nagios username: nagiosadmin, password: 2cc4722591074a1b

Even though not noted, I've installed an ntp instance and daemon shows as running as that was given as a possible problem.

ntp       9634     1  0 13:13 ?        00:00:00 /usr/sbin/ntpd -u ntp:ntp -g

Any ideas?

Thanks.

edit retag flag offensive close merge delete

Comments

Make sure you have the package auditd installed?

mpetason gravatar imagempetason ( 2015-01-05 14:43:34 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-05 15:08:44 -0500

phillw gravatar image

updated 2015-01-05 15:37:36 -0500

Thanks, having done some (read a lot) of digging, it appears OVH have their own kernel, and not the standard one. I'm just replacing it.

Indeed, switching to 'standard' kernel has solved the issue.

Now to find out why it has not used the pre-setup cinder-volumes LVM. But I think that is a different set of instructions.

But, for people reporting the error I saw, they need to replace the OVH kernel with a standard CentOS kernel.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-04 12:21:02 -0500

Seen: 305 times

Last updated: Jan 05 '15