Ask Your Question
1

Devstack on Ubuntu 14.04 failed with Python setup error

asked 2015-01-02 16:15:44 -0500

SridharRamaswamy gravatar image

updated 2015-01-04 23:21:15 -0500

A simple devstack installation on Ubuntu 14.04 fails with python setup.py error in Mako package,

http://paste.openstack.org/show/155427/

Collecting Mako (from alembic>=0.6.4->oslo.db>=1.1.0->keystone==2015.1.dev47)
...
ValueError: ("EntryPoint must be in 'name=module:attrs [extras]' format", 'html+mako = mako.ext.pygmentplugin:MakoHtmlLexer')

This is same on a brand new Ubuntu VM. My local.conf is pretty barebone as in http://paste.openstack.org/show/155428/

Any clues ?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-01-02 22:59:43 -0500

dtroyer gravatar image

This was caused by a regression in the setuptools 10.2 release... version 10.2.1 was released later this afternoon (20Jan2015) and corrects the problem.

edit flag offensive delete link more

Comments

thanks ... will retry with newer setuptools!

SridharRamaswamy gravatar imageSridharRamaswamy ( 2015-01-04 23:22:15 -0500 )edit

Did that following,

$ sudo pip uninstall setuptools $ sudo pip install setuptools==10.2.1

.. and devstack came up fine! Thanks a lot for your help.

SridharRamaswamy gravatar imageSridharRamaswamy ( 2015-01-05 19:32:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-01-02 16:15:44 -0500

Seen: 462 times

Last updated: Jan 04 '15