Ask Your Question

Installing DevStack, unable to connect to

asked 2014-12-31 11:32:55 -0500

AlonFre gravatar image

updated 2014-12-31 12:29:53 -0500

smaffulli gravatar image

Hi, i'm trying to install Devstack using this guide:

after lunching the ./ i get this error:

fatal: unable to connect to[0:]: errno=Connection timed out[1:]: errno=Connection timed out[2: 2001:4800:7818:104:be76:4eff:fe04:6c24]: errno=Network is unreachable[3: 2001:4800:7818:104:be76:4eff:fe04:7072]: errno=Network is unreachable

+ [[ 128 -ne 124 ]]
+ die 672 'git call failed: [git clone' git:// '/opt/stack/requirements]'
+ local exitcode=0
+ set +o xtrace
[Call Trace]
[ERROR] /home/stack/devstack/functions-common:672 git call failed: [git clone git:// /opt/stack/requirements]
Error on exit
World dumping... see ./worlddump-2014-12-31-171546.txt for details
df: '/run/user/1000/gvfs': Permission denied
df: '/media/devstack/6870-6430': Permission denied

but when trying to reach "" using the web browser it works fine. can you please advice?

Thanks in advance, Alon.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2015-02-10 10:14:49 -0500

singhspk gravatar image

Sometimes git:// urls won't work. You can instruct git to use https:// instead with the following command: git config --global url."https://".insteadOf git://

edit flag offensive delete link more


worked for me . Thanks :)

Bharath Kumar gravatar imageBharath Kumar ( 2015-09-29 22:50:26 -0500 )edit

answered 2014-12-31 12:29:23 -0500

smaffulli gravatar image

You're probably behind a proxy and your browser is configured properly to access Internet, while your command line applications are not.

edit flag offensive delete link more


in my browther "use system proxy proxy setting" but also when i change it to "No proxy" i'm able to access this website. in addition, i tried using wget from the command line, and i can enter this website. any other suggestions? maybe its related to some permissions?! see last line in the log fil

AlonFre gravatar imageAlonFre ( 2015-01-07 05:14:16 -0500 )edit

answered 2015-04-21 19:01:02 -0500

whg gravatar image

another option is set GIT_BASE to use https instead of git

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-12-31 11:32:55 -0500

Seen: 13,627 times

Last updated: Apr 21 '15