Ask Your Question
1

Cannot launch instance after creating demo-net

asked 2014-12-31 05:33:45 -0500

gparaskevas gravatar image

updated 2014-12-31 12:35:53 -0500

smaffulli gravatar image

Hello there my error is a litle complicated. I was able to launch instances but without network(nova-network). Then i configured my network devices and created a demo-net. I use single-nic nodes so i use a bridge for node comunications. The error on Horizon is "Error: Failed to launch instance "test": Please try again later [Error: No valid host was found. ]. "

The nova-compute.log:

"2014-12-31 13:16:57.947 2820 TRACE nova.compute.manager [instance: 92d2414c-85fd-4190-a055-d2b49a529c62] AgentError: Error during following call to agent: ['ovs-vsctl', '--timeout=120', '--', '--may-exist', 'add-port', 'br-int', 'gw-149fd32e-00', '--', 'set', 'Interface', 'gw-149fd32e-00', 'type=internal', '--', 'set', 'Interface', 'gw-149fd32e-00', 'external-ids:iface-id=gw-149fd32e-00', '--', 'set', 'Interface', 'gw-149fd32e-00', 'external-ids:iface-status=active', '--', 'set', 'Interface', 'gw-149fd32e-00', 'external-ids:attached-mac=fa:16:3e:37:6f:0a']
2014-12-31 13:16:57.947 2820 TRACE nova.compute.manager [instance: 92d2414c-85fd-4190-a055-d2b49a529c62]
2014-12-31 13:16:57.947 2820 TRACE nova.compute.manager [instance: 92d2414c-85fd-4190-a055-d2b49a529c62]
2014-12-31 13:16:57.962 2820 WARNING nova.virt.libvirt.driver [-] [instance: 92d2414c-85fd-4190-a055-d2b49a529c62] During wait destroy, instance disappeared.
2014-12-31 13:23:55.558 2820 WARNING nova.compute.manager [-] Bandwidth usage not supported by hypervisor.
2014-12-31 13:24:54.613 2820 WARNING nova.compute.manager [-] While synchronizing instance power states, found 1 instances in the database and 0 instances on the hypervisor."
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-03 02:52:19 -0500

gparaskevas gravatar image

More details are: Debian 7.7 Nova-network LVM driver for cinder.

edit flag offensive delete link more

Comments

I met the exactly same issue. Please let me know if you managed to fix this. Thank you in advance.

Luigi gravatar imageLuigi ( 2015-07-15 07:00:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-31 05:33:45 -0500

Seen: 458 times

Last updated: Jan 03 '15