Ask Your Question
0

Why am I unable to download the Grizzly version from Ubuntu repositories?

asked 2013-04-29 02:15:46 -0500

Bhavaniprasad gravatar image

updated 2013-05-01 12:34:30 -0500

smaffulli gravatar image

I am trying to install openstack Grizzly version. Before installing i will have to set the repository. i have configured repo as openstack suggested document echo deb http://ubuntu-cloud.archive.canonical.com/ubuntu precise-updates/grizzly main >> /etc/apt/sources.list.d/grizzly.list

Still i am getting essex 2012.1 version.

While executing apt-get update I get the following errors:

W: Failed to fetch gzip:/var/lib/apt/lists/partial/ubuntu-cloud.archive.canonical.com_ubuntu_dists_precise-updates_grizzly_main_binary-amd64_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/ubuntu-cloud.archive.canonical.com_ubuntu_dists_precise-updates_grizzly_main_binary-i386_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/ubuntu-cloud.archive.canonical.com_ubuntu_dists_precise-updates_grizzly_main_i18n_Translation-en%5fUS  Encountered a section with no Package: header

W: Failed to fetch gzip:/var/lib/apt/lists/partial/ubuntu-cloud.archive.canonical.com_ubuntu_dists_precise-updates_grizzly_main_i18n_Translation-en  Encountered a section with no Package: header

E: Some index files failed to download. They have been ignored, or old ones used instead.

Please guide me how to get Grizzly version by using manual commands (not devstack installation).

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2013-06-12 23:40:44 -0500

Bhavaniprasad gravatar image

it got resolved. it is just because of internal firewall issue.

edit flag offensive delete link more
1

answered 2013-04-29 03:23:12 -0500

updated 2013-05-01 12:31:50 -0500

smaffulli gravatar image

Those commands should work (Ubuntu 12.04 LTS):

apt-get install -y ubuntu-cloud-keyring
echo "deb http://ubuntu-cloud.archive.canonical.com/ubuntu precise-updates/grizzly main" >> /etc/apt/sources.list.d/cloud-archive.list
apt-get update

If that is not enough, clean the apt cache:

 rm -r /var/lib/apt/lists/partial/*

and then try to upgrade again:

  apt-get update && apt-get upgrade

You may want to remove also the files from /etc/apt/sources.list.d/ and run apt-get update again.

edit flag offensive delete link more

Comments

i am using ubuntu 12.04 version.

Bhavaniprasad gravatar imageBhavaniprasad ( 2013-04-29 04:12:12 -0500 )edit

still i m getting same error.

Bhavaniprasad gravatar imageBhavaniprasad ( 2013-04-29 05:48:46 -0500 )edit

rm -r /var/lib/apt/lists/partial/* and then: apt-get update && apt-get upgrade

Alen Komljen gravatar imageAlen Komljen ( 2013-04-29 06:00:16 -0500 )edit

after successful exectution of rm -r /var/lib/apt/lists/partial/* command got same error.

Bhavaniprasad gravatar imageBhavaniprasad ( 2013-04-29 06:03:00 -0500 )edit

Ok, make sure this location is empty: /var/lib/apt/lists/partial/ and this one: /etc/apt/sources.list.d/. After that try apt-get update.

Alen Komljen gravatar imageAlen Komljen ( 2013-04-29 06:09:47 -0500 )edit
0

answered 2013-05-13 03:40:11 -0500

bvivek gravatar image

I faced the same issue and solved it the following way: 1. Download the package manually from "packages.ubuntu.com" 2. Install gdebi (apt-get install gdebi) 3. Install the package (gdebi <package name="">)

gdebi installs the package by resolving all the dependencies.

Hope this helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-29 02:15:46 -0500

Seen: 1,446 times

Last updated: Jun 12 '13