Ask Your Question
1

rabbitmq "Error: unable to connect to node 'rabbit@OS-controller': nodedown"

asked 2014-12-30 15:31:58 -0600

I am trying to install OpenStack on CentOS 7 by following the official documentation at: http://docs.openstack.org/juno/install-guide/install/yum/content/ch_basic_environment.html#basics-messaging-server (http://docs.openstack.org/juno/instal...)

and after starting the server, I try to check the status, and I get:

rabbitmqctl status
Status of node 'rabbit@OS-controller' ...
Error: unable to connect to node 'rabbit@OS-controller': nodedown

DIAGNOSTICS
===========

nodes in question: ['rabbit@OS-controller']

hosts, their running nodes and ports:
- OS-controller: [{rabbitmqctl30801,50119}]

current node details:
- node name: 'rabbitmqctl30801@OS-controller'
- home dir: /var/lib/rabbitmq
- cookie hash: qjmursdWY1l7OJSWpqPKew==

Everything is default, I just installed it by

yum install rabbitmq-server

and then

systemctl enable rabbitmq-server.service
systemctl start rabbitmq-server.service

Does anybody know why am I getting this error?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-12-31 01:48:53 -0600

rahulrajvn gravatar image

Please try restarting the rabbitmq-server after you logged in to the controller.

systemctl restart rabbitmq-server.service

I am also facing the same issue but once the server is up and when I restart the rabbitm1-server for one or two time it get to working.

edit flag offensive delete link more

Comments

yeah...exactly...solved my problem. Thanks.

hem gravatar imagehem ( 2016-10-03 10:18:49 -0600 )edit
1

answered 2014-12-30 18:53:53 -0600

Byungjoon Lee gravatar image

Maybe, the rabbitmq is running on different hostname. In your configuration, you are accessing the rabbitmq running on OS-controller. I think your hostname is set to it.

Just see under /var/log/rabbitmq/. There you might found various log files. If there is a log file rabbit@localhost.log , that is an indication that you should change the hostname into 'localhost' again. Change it, and do systemctl restwart rabbitmq-server.

I know this is weird - why rabbitmq does not operates solely on IP address and use hostname value in such a non-typical way?

edit flag offensive delete link more
0

answered 2017-03-05 11:04:56 -0600

nitin gautam gravatar image

it works as it was searching for the hostname entry into your system which counterparts its configuration file if have already set any hostname so if you change it to the default it started working

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-12-30 15:31:58 -0600

Seen: 26,315 times

Last updated: Dec 31 '14