Ask Your Question
0

unable to verify connectivity on "initial network"

asked 2014-12-28 18:48:49 -0500

francois gravatar image

updated 2015-01-03 14:59:27 -0500

I am building JUNO on Centos 7 (1 controller, 1 network, 2 compute nodes) bare-metal 4 physical nodes link text

I am stuck at "verify connectivity" it say ping -c 4 203.0.113.101

IT SAY "

If you configured your external physical network and virtual networks correctly, you should be able to ping this IP address from any host on your external physical network.

" I can see the problem in /var/log/neutron/openvswitch-agent.log - how do I fix it?

ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-f415c2ac-bf31-402c-bff8-169c1878e939 None] Bridge br-vlan for physical network physnet1 does not exist. Agent terminated!

br-vlan does exist

[root@network ~]# ovs-vsctl show
a9f7a8c9-c31e-4899-a819-000cdbabeddf
    Bridge br-tun
        Port "gre-c0a8075b"
            Interface "gre-c0a8075b"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.7.80", out_key=flow, remote_ip="192.168.7.91"}
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-c0a8075a"
            Interface "gre-c0a8075a"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="192.168.7.80", out_key=flow, remote_ip="192.168.7.90"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-vlan
        Port phy-br-vlan
            Interface phy-br-vlan
                type: patch
                options: {peer=int-br-vlan}
        Port "qg-83f19a07-ab"
            Interface "qg-83f19a07-ab"
                type: internal
        Port "eno1"
            Interface "eno1"
        Port br-vlan
            Interface br-vlan
                type: internal
    Bridge br-int
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
        Port int-br-vlan
            Interface int-br-vlan
                type: patch
                options: {peer=phy-br-vlan}
        Port "qr-9d31d600-fe"
            tag: 1
            Interface "qr-9d31d600-fe"
                type: internal
    ovs_version: "2.1.3"

and so is physnet1 it is on both the controller and the network nodes

network

[root@network ~]# grep -v '^#' /etc/neutron/plugins/ml2/ml2_conf.ini|grep [a-zA-Z]
[ml2]
type_drivers = vlan,gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
network_vlan_ranges = physnet1:208:2234
[ml2_type_gre]
[ml2_type_vxlan]
[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[ovs]
local_ip = 192.168.7.80
enable_tunneling = True
bridge_mappings = physnet1:br-vlan
[agent]
tunnel_types = gre

controller

[root@controller ~]# grep -v '^#' /etc/neutron/plugins/ml2/ml2_conf.ini|grep [a-zA-Z]
[ml2]
type_drivers = vlan, gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
network_vlan_ranges = physnet1:208:2234
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[ovs]
[agent]
tunnel_types = gre

the namespace looks fine too, and appears to be working fine as well

 ip  netns exec qrouter-c2c8b397-0e50-4c30-b442-52116161c002 ip a 
 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
     inet6 ::1/128 scope host 
        valid_lft forever preferred_lft forever
 12: qr-9d31d600-fe: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
     link/ether fa:16:3e:76:6c:e6 brd ff:ff:ff:ff:ff:ff
     inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-9d31d600-fe
        valid_lft forever preferred_lft forever
     inet6 fe80::f816:3eff:fe76:6ce6/64 scope link 
        valid_lft forever preferred_lft forever
 13: qg-83f19a07-ab: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
     link/ether fa:16:3e:c9:e9:97 brd ff ...
(more)
edit retag flag offensive close merge delete

Comments

i' a little bit confused you're using for floating IP's the external vlan bridge correct ? all vlan (floating) IP's represtented by net01. Please show me your networks:

neutron net-show <net>

and the subnets

neutron subnet-show <subnet>
foexle gravatar imagefoexle ( 2014-12-31 03:39:42 -0500 )edit

First of all, many thanks foexie for taking time to read questions, here is my net and subnet details

I am editing the question there is not enough space in the comments section

francois gravatar imagefrancois ( 2014-12-31 09:07:22 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-03 19:53:02 -0500

francois gravatar image

updated 2015-01-03 19:54:16 -0500

fixed yeah (4 rebuild later, you learn so much from solving problem)

l3-agent failed to set vlan tag on gateway ports on br-vlan. pretty obvious now

but why? that would be another question

 ovs-vsctl set port <dev qg-xxxxxxxx-xx> tag=<provider:segmentation_id>

I can now ping the world "hello world" ;-)

edit flag offensive delete link more

Comments

Hi, I met the same problem. Could you please give more details about how to solve this problem? For example, how did you get the port and tag value? Thank you in advance.

Tenma gravatar imageTenma ( 2015-05-27 18:32:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-28 18:48:49 -0500

Seen: 1,023 times

Last updated: Jan 03 '15