Ask Your Question
0

how to debug horizon connection problem

asked 2014-12-27 07:52:44 -0500

fxp gravatar image

Hello,

I'm just getting started with openstack using devstack and following the quick start guide w/the all in one single machine setup on a home network. Everything seems to have gone fine with the install and startup but I can't connect to the Horizon dashboard. As recommended I changed the host machine's IP to be static. Here is what I know so far: - From my MAC book Pro I can ping the host IP but I can't connect to the Horizon dashboard. - In stack.sh.log.summary I can see "Configuring and starting Horizon" among the status messages. - running "sudo netstat -nap | grep 80" shows httpd listening on 0.0.0.0:80. - I don't think the linksys is interfering as from the same laptop I can connect to a NAS hosted dashboard I have on the same network. - After a failed attempt if I look under /etc/httpd/logs I don't see any recent logging activity. Its as though packets aren't being delivered to httpd.

Any suggestions or pointers would be appreciated. Thanks, fxp

edit retag flag offensive close merge delete

Comments

For more debugging from HORIZON side, you can enable the debug level for httpd in the file /etc/httpd/conf/httpd.conf

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel debug
Ranjit gravatar imageRanjit ( 2014-12-30 01:55:56 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-12-27 23:45:20 -0500

Bipin gravatar image

updated 2014-12-27 23:47:02 -0500

Hello,

Did you make sure the port 80 is allowed in the firewall ?

-A INPUT -p tcp -m state --state NEW -m tcp --dport 80 -j ACCEPT

Whats the status of telnet to port 80 of controller node ?

Regards

edit flag offensive delete link more

Comments

Hi,

The firewall looked ok but I entered the above to make sure. I am unable to telnet to that port though.

MacBook-Pro:C fxp$ telnet 192.168.1.113 80 Trying 192.168.1.113... telnet: connect to address 192.168.1.113: Connection refused telnet: Unable to connect to remote host

Thanks

fxp gravatar imagefxp ( 2014-12-28 08:02:55 -0500 )edit
0

answered 2015-01-30 11:30:06 -0500

fxp gravatar image

Hi all,

I finally got back to this recently. Turns out the problem was an entry in the INPUT chain of iptables. I took a closer look at iptables after running tcpdump and seeing that the server was generating ICMP host prohibited responses.

Thanks, fxp

edit flag offensive delete link more

Comments

Glad to know, its Fixed.

Bipin gravatar imageBipin ( 2015-01-31 23:21:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-27 07:51:05 -0500

Seen: 446 times

Last updated: Jan 30 '15