Ask Your Question
0

Installing dependency error packstack

asked 2014-12-26 21:32:54 -0500

fresher gravatar image

I am getting following error while installing openstack juno using packstack.

Installing Dependencies [ ERROR ]

ERROR : Failed to run remote script, stdout: Loaded plugins: fastestmirror

stderr: Warning: Permanently added '10.129.2.57' (RSA) to the list of known hosts.
+ trap t ERR
+ yum install -y puppet hiera openssh-clients tar nc rubygem-json


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64
++ t
++ exit 1

I manually installed

 yum install -y puppet hiera openssh-clients tar nc rubygem-json

and again ran packstack but I am getting the same error.Please help me.

edit retag flag offensive close merge delete

Comments

Install EPEL 7 manually && in repos files switch from $mirrors ( CentOS ) to $baseurl, then run packstack via previous answer-file. Something is wrong with your local CentOS mirrors.

dbaxps gravatar imagedbaxps ( 2014-12-27 01:31:02 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-04-17 14:06:18 -0500

nubber gravatar image

Yum update. does the trick in my case.

edit flag offensive delete link more
0

answered 2014-12-27 01:38:31 -0500

dbaxps gravatar image

Install EPEL 7 manually && under /etc/yum.repos.d in epel.repo file switch from $mirrorlist to $baseurl, then run packstack via previous answer-file. Something is wrong with your local CentOS mirrors.

[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
# mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-26 21:32:54 -0500

Seen: 1,165 times

Last updated: Dec 27 '14