instance don't receive ip

asked 2014-12-25 09:31:42 -0600

yaroni gravatar image

updated 2014-12-28 03:31:28 -0600

I installed packstack all in one with following manual on physical server CentOS Linux 7 (Core)
But the instance i launch cirros don't get ip, not private and not public
openstack.redhat.com/Neutron_with_existing_external_network
openstack.redhat.com/Running_an_instance_with_Neutron
I deleted the public network and created a new one with following command

neutron subnet-create --name public_subnet --enable_dhcp=False --allocation-pool=start=172.16.7.1,end=172.16.7.20  --gateway=172.16.1.1 public 172.16.7.0/16

Here is the configuration on my physical server

cat /etc/sysconfig/network-scripts/ifcfg-br-ex
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=172.16.4.250
NETMASK=255.255.0.0
GATEWAY=172.16.1.1
DNS=172.16.1.121
ONBOOT=yes

cat /etc/sysconfig/network-scripts/ifcfg-enp3s0f0
HWADDR=68:B5:99:CD:E6:24
NAME=enp3s0f0
UUID=d6f2025c-780d-4cc5-b3f4-84a8d3dc5e5a
ONBOOT=yes
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex

Here are some log parts from cirros instance

ifconfig -a
eth0      Link encap:Ethernet  HWaddr FA:16:3E:12:51:44  
          inet6 addr: fe80::f816:3eff:fe12:5144/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:804 (804.0 B)  TX bytes:1132 (1.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

tarting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
Usage: /sbin/cirros-dhcpc <up|down>
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.99
checking http://169.254.169.254/2009-04-04/instance-id
failed 1/20: up 181.00. request failed
failed 2/20: up 183.02. request failed
failed 3/20: up 185.02. request failed
failed 4/20: up 187.03. request failed
failed 5/20: up 189.03. request failed
failed 6/20: up 191.04. request failed
failed 7/20: up 193.04. request failed
failed 8/20: up 195.05. request failed
failed 9/20: up 197.05. request failed
failed 10/20: up 199.06. request failed
failed 11/20: up 201.06. request failed
failed 12/20: up 203.07. request failed
failed 13/20: up 205.07. request failed
failed 14/20: up 207.08. request failed
failed 15/20: up 209.08. request failed
failed 16/20: up 211.09. request failed
failed 17/20: up 213.09. request failed
failed 18/20: up 215.10. request failed
failed 19/20: up 217.11. request failed
failed 20/20: up 219.11. request failed
failed to read iid from metadata. tried 20 ...
(more)
edit retag flag offensive close merge delete

Comments

i have the same problem and have no idea, you resolved it by the time ??oh god...

349317925 gravatar image349317925 ( 2015-07-02 02:00:27 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-12-27 13:53:31 -0600

yaroni gravatar image

updated 2014-12-27 14:17:13 -0600

are you sure i need to run the ovs, because the installation command that i run (from rdo site) is packstack --allinone --provision-all-in-one-ovs-bridge=n

how do you restart neutron service i rebooted the machine but it didn't help, still no ip

edit flag offensive delete link more
0

answered 2014-12-25 23:27:48 -0600

Amitabh Sinha gravatar image

Openstack-nova-network is inactive (disabled on boot) as well as neutron-lbaas-agent is inactive (disabled on boot . same issue I have faced earlier (vm-ip) . I reinstalled ovs and restarted all the neutron services.I worked for me. Hope it will work for you also.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-25 09:30:05 -0600

Seen: 1,052 times

Last updated: Dec 28 '14