Ask Your Question
0

puppet error

asked 2014-12-25 09:29:50 -0500

fresher gravatar image

I got the following error while installing openstack on centos7 using packstack

ERROR : Failed to run remote script, stdout: Loaded plugins: fastestmirror, priorities

stderr: Warning: Permanently added '10.129.2.57' (ECDSA) to the list of known hosts.
+ trap t ERR
+ yum install -y puppet hiera openssh-clients tar nc rubygem-json

when I do systemctl status -l puppet I get

puppet.service - Puppet agent
   Loaded: loaded (/usr/lib/systemd/system/puppet.service; disabled)
   Active: active (running) since Thu 2014-12-25 20:50:29 IST; 4s ago
 Main PID: 2889 (start-puppet-ag)
   CGroup: /system.slice/puppet.service
           ├─2889 /bin/sh /usr/bin/start-puppet-agent agent  --no-daemonize
           └─2890 /usr/bin/ruby /usr/bin/puppet agent --no-daemonize

Dec 25 20:50:29 server2 systemd[1]: Starting Puppet agent...
Dec 25 20:50:29 server2 systemd[1]: Started Puppet agent.
Dec 25 20:50:33 server2 puppet-agent[2890]: Could not request certificate: getaddrinfo: Name or service not known

My /etc/hostname contains:

server2

My /etc/hosts contains:

127.0.0.1   server2 server2.localdomain localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
edit retag flag offensive close merge delete

Comments

did that. Still the problem persists. Actually in my first run of packstack the /etc/hostname contained server2 localhost.localdomain. Is it because of that it is creating problem that it has added it to its list? How can I overcome it?

fresher gravatar imagefresher ( 2014-12-25 22:25:21 -0500 )edit

It is empty. I reinstalled OS to remove any previous configurations but still getting the same error

fresher gravatar imagefresher ( 2014-12-26 05:09:48 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2014-12-25 09:45:42 -0500

dbaxps gravatar image

updated 2015-01-09 19:03:01 -0500

smaffulli gravatar image

Try to remove server2 server2.localdomain from line 127.0.0.1 and create first line:

192.168.xx.xx server2 server2.localdomain
/etc/hostname contains server2.localdomain

Check pupplet logs and don't touch /etc/hosts leave as is or make correct entries. Configure FQDN in /etc/hostname. Run packstack --answer-file=MultiNode.txt.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-25 09:29:50 -0500

Seen: 1,093 times

Last updated: Jan 09 '15