Ask Your Question

rabbitmq startup error [closed]

asked 2014-12-25 04:22:42 -0500

fresher gravatar image

updated 2014-12-25 07:25:45 -0500

I get the following error when installing openstack juno in CentoOS7 using packstack

ERROR : Error appeared during Puppet run:
Error: Could not start Service[rabbitmq-server]: Execution of '/usr/bin/systemctl start rabbitmq-server' returned 1: Job for rabbitmq-server.service failed. See 'systemctl status rabbitmq-server.service' and 'journalctl -xn' for details.
You will find full trace in log /var/tmp/packstack/20141225-150535-2i99oU/manifests/
Please check log file /var/tmp/packstack/20141225-150535-2i99oU/openstack-setup.log for more information

I am getting a new error now before reaching the rabbit_mq step:

ERROR : Failed to run remote script, stdout: Loaded plugins: fastestmirror, priorities

stderr: Warning: Permanently added '' (ECDSA) to the list of known hosts.
+ trap t ERR
+ yum install -y puppet hiera openssh-clients tar nc rubygem-json

One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64
++ t
++ exit 1

My yum update is working

puppet agent -t --debug --verbose gives this error

Error: Could not request certificate: getaddrinfo: Name or service not known
edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by rbowen
close date 2015-06-02 15:57:20.156304


Try systemctl start rabbitmq-server from CLI and watch 'journalctl -xn'

dbaxps gravatar imagedbaxps ( 2014-12-25 05:39:21 -0500 )edit

Set SELINUX=permissive (reboot) or setenforce 0 before running packstack

dbaxps gravatar imagedbaxps ( 2014-12-25 05:41:34 -0500 )edit

Run as root

# yum install -y puppet hiera openssh-clients tar nc rubygem-json
dbaxps gravatar imagedbaxps ( 2014-12-25 07:05:21 -0500 )edit

updated the question

fresher gravatar imagefresher ( 2014-12-25 08:26:44 -0500 )edit

Run from CLI

# yum install -y puppet hiera openssh-clients tar nc rubygem-json
dbaxps gravatar imagedbaxps ( 2014-12-25 08:50:57 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-12-25 07:08:37 -0500

dbaxps gravatar image

updated 2014-12-25 07:10:48 -0500

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-12-25 04:22:42 -0500

Seen: 1,656 times

Last updated: Dec 25 '14