Ask Your Question
0

Make existing public network available

asked 2014-12-24 02:52:04 -0500

Anonymouslemming gravatar image

Hi all,

I have a 2-node openstack installation now working, created with packstack and I can create instances on private networks.

I'm now trying to connect my existing public network to this so that other nodes on the network can connect to Openstack instances, but struggling. What is the right way to make an existing network available for floating IP addresses ?

My openstack dashboard is on my public network (192.168.10.0/24). This is the network I wish to add to my Openstack deployment

If I try and add a new network of type 'External Network' provider network type 'Local' it fails and I get an error in the neutron server log saying

2014-12-24 08:44:49.677 3890 INFO neutron.api.v2.resource [req-aed42425-a3ae-45ae-b7ce-0a806182b3ab None] create failed (client error): Invalid input for operation: network_type value 'local' not supported.

If I create the network as a VXLAN network, it succeeds. But I'm not sure VXLAN is the right solution for adding the existing local network ?

image description

After creating a working VXLAN external network, any router created on this network always has the gateway port in a DOWN state:

image description

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-12-24 02:59:42 -0500

dbaxps gravatar image

updated 2014-12-24 05:32:24 -0500

All is done OK. Try to assign floating IP to VM.

[root@juno1 ~(keystone_admin)]# neutron net-list | grep public
| 65cbd354-daae-41bb-9d3c-e58b1062be19 | public          | 147d5ecd-fe39-489e-8901-3b20a2c50148 192.168.1.0/24 |
[root@juno1 ~(keystone_admin)]# neutron net-show 65cbd354-daae-41bb-9d3c-e58b1062be19
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 65cbd354-daae-41bb-9d3c-e58b1062be19 |
| name                      | public                               |
| provider:network_type     | vxlan                                |
| provider:physical_network |                                      |
| provider:segmentation_id  | 1001                                 |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 147d5ecd-fe39-489e-8901-3b20a2c50148 |
| tenant_id                 | 2561f253faca48399d0cc77886574e1d     |
+---------------------------+--------------------------------------+

[root@juno1 network-scripts(keystone_admin)]# cat ifcfg-br-ex
    DEVICE="br-ex"
    BOOTPROTO="static"
    IPADDR="192.168.1.127"
    NETMASK="255.255.255.0"
    DNS1="83.221.202.254"
    BROADCAST="192.168.1.255"
    GATEWAY="192.168.1.1"
    NM_CONTROLLED="no"
    DEFROUTE="yes"
    IPV4_FAILURE_FATAL="yes"
    IPV6INIT=no
    ONBOOT="yes"
    TYPE="OVSIntPort"
    OVS_BRIDGE=br-ex
    DEVICETYPE="ovs"

    [root@juno1 network-scripts(keystone_admin)]# cat ifcfg-enp2s0
    DEVICE="enp2s0"
    # HWADDR=00:22:15:63:E4:E2
    ONBOOT="yes"
    TYPE="OVSPort"
    DEVICETYPE="ovs"
    OVS_BRIDGE=br-ex
    NM_CONTROLLED=no
    IPV6INIT=no
edit flag offensive delete link more

Comments

I can assign a floating IP but not ping it (even directly from the controller node) and the port in the router remains DOWN. And I have setup the security group to allow all ICMP and all TCP, exactly as I did (and worked) on an allinone deployment.

Anonymouslemming gravatar imageAnonymouslemming ( 2014-12-24 03:44:55 -0500 )edit

Port Down is normal.

dbaxps gravatar imagedbaxps ( 2014-12-24 03:53:51 -0500 )edit

Post ovs-vsctl show && ifconfig on Controller.

dbaxps gravatar imagedbaxps ( 2014-12-24 04:06:01 -0500 )edit
Anonymouslemming gravatar imageAnonymouslemming ( 2014-12-24 04:12:28 -0500 )edit

eth0 should be OVS port of OVS bridge br-ex ( should have IP which had eth0).

dbaxps gravatar imagedbaxps ( 2014-12-24 04:41:04 -0500 )edit
0

answered 2015-10-28 21:57:28 -0500

Mohit gravatar image

I had the same issue at my end on Kilo Installation , fixed it by updating the file /etc/neutron/plugins/ml2/ml2_conf.ini

type_drivers=local
tenant_network_types=local
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-24 02:52:04 -0500

Seen: 1,699 times

Last updated: Oct 28 '15