Ask Your Question
0

API Identity with Public IP?

asked 2014-12-23 09:36:10 -0600

Mr. Doe gravatar image

updated 2014-12-23 09:37:04 -0600

The API identity of my project is: http://192.168.0.10:5000/v2.0 (i used the default installation, that's the ip of my host). The ip is private and since i want that web can acess to my project i want a public ip.

The question is: how can i set that url with a public ip? I have to ask to my provider or there is a faster solution?

edit retag flag offensive close merge delete

Comments

if i am understanding well,the 192.168.0.10 is a private ip and you want the outside world can access your keystone service?

9lives gravatar image9lives ( 2014-12-23 19:24:13 -0600 )edit

Yes but i found the problem: actualy i can't set a private ip with my provider, sigh.

Mr. Doe gravatar imageMr. Doe ( 2014-12-24 02:44:10 -0600 )edit

did you try to setup reverse proxy or use iptables to set up DNAT to allow the out side ip address access your internally keystone services?

9lives gravatar image9lives ( 2014-12-24 03:00:32 -0600 )edit

I set the NAT of my router to "open" then i tried install Devstack using HOST_IP=(my dynamic public ip, i need that he work that session so dynamic is ok for me) but doesen't work, the installation fail.

Mr. Doe gravatar imageMr. Doe ( 2014-12-24 04:25:51 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-12-24 07:10:17 -0600

Mr. Doe gravatar image

I installed Openstack, i didn't used HOST_IP since, by defult, openstack use my private ip for that (192.168.0.14). Then i did like you said:

iptables -t nat -A PREROUTING -d 79.3.191.226 -j DNAT --to-destination 192.168.0.14

(79.blabla) is my dynamic public ip that provider assigned me). But nothing change, when i try connect the cloud to platform (using my API identity http://192.168.0.14:5000/v2.0 ) the platform say ERROR from prioder, no route to host.

edit flag offensive delete link more
0

answered 2014-12-24 04:49:02 -0600

9lives gravatar image

updated 2014-12-24 04:51:40 -0600

force to use answer field for the comments limitation

ok, i think you need to use the private ip which is assigned by your router as the HOST_IP and install OpenStack via devstack then configure your router to use port forwarding or DNAT to let the out side to access your openstack instance like this

iptables -t nat -A PREROUTING -d 202.202.202.1 -j DNAT --to-destination 192.168.0.10

202.202.202.1 : is your dynamic public ip assigned by your ISP
192.168.0.10   : is your private ip assigned by your router dhcp server.

Hope that helps!

Vic

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-12-23 09:36:10 -0600

Seen: 195 times

Last updated: Dec 24 '14