Ask Your Question
0

swift container-server.conf error

asked 2014-12-22 15:15:50 -0600

Stephanie Fuller gravatar image

When I try to start swift services, 3 of them fail - the account, container & object services. I get this output:

[root@e1 ~]# swift-init container-server start Starting container-server...(/etc/swift/container-server.conf) Traceback (most recent call last): File "/bin/swift-container-server", line 23, in <module> sys.exit(run_wsgi(conf_file, 'container-server', **options)) File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 445, in run_wsgi loadapp(conf_path, global_conf=global_conf) File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 354, in loadapp ctx = loadcontext(loadwsgi.APP, conf_file, global_conf=global_conf) File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 338, in loadcontext global_conf=global_conf) File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext global_conf=global_conf) File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 320, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 61, in get_context object_type, name=name, global_conf=global_conf) File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 450, in get_context global_additions=global_additions) File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 562, in _pipeline_app_context for name in pipeline[:-1]] File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 61, in get_context object_type, name=name, global_conf=global_conf) File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 458, in get_context section) File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 514, in _context_from_explicit "No loader given in section %r" % section)

LookupError: No loader given in section 'filter:recon'

My swift/account-server.conf file is as follows:

[root@e1 ~]# cat /etc/swift/account-server.conf [DEFAULT] bind_ip = controllerIP bind_port = 6002 user = swift swift_dir = /etc/swift devices = /srv/node mount_check = false log_facility = LOG_LOCAL2 workers = 1

[pipeline:main] #pipeline = account-server ###SRF, change per juno install guide instructions... pipeline = healthcheck recon account-server

[filter:recon} recon_cache_path = /var/chche/swift

[filter:healthcheck] use = egg:swift#healthcheck

[app:account-server] use = egg:swift#account set log_name = account-server set log_facility = LOG_LOCAL2 set log_level = INFO set log_requests = True set log_address = /dev/log

[account-replicator] concurrency = 8

[account-auditor]

[account-reaper] concurrency = 8

What is missing in the [filter:recon] section??? What is a loader? how do I specify it in the config file???

edit retag flag offensive close merge delete

Comments

After posting the question I noticed some typos in the conf file. I fixed those, and still had the same error about a loader in the [filter:recon] section.

So, I tried changing the pipeline to only have the account-server. That worked. What is pipeline & do I want/need healthcheck & recon?

Stephanie Fuller gravatar imageStephanie Fuller ( 2014-12-22 16:29:41 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-13 02:04:51 -0600

You miss in [filter:recon] some configuration entries.

You can set correctly with

openstack-config --set /etc/swift/container-server.conf filter:recon use 'egg:swift#recon'
openstack-config --set /etc/swift/container-server.conf filter:recon recon_cache_path /var/cache/swift
openstack-config --set /etc/swift/container-server.conf filter:recon container_recon true

if you don't have openstack-config, paste this on your config file:

[filter:recon]
use = egg:swift#recon
recon_cache_path = /var/cache/swift
container_recon = true

This is valid for container config. If you need the config for account or object server, replace container with object or account

edit flag offensive delete link more

Comments

thx it worked for mine setup.

is it possible if we define loader for recon in /etc/swift/proxy-server.conf and try ?

vaibhavhyd2014 gravatar imagevaibhavhyd2014 ( 2015-06-29 01:19:33 -0600 )edit
0

answered 2015-01-12 17:13:47 -0600

zaitcev gravatar image

You must have a use= statement in the [filter:recon] section. Or, you could run without recon if the cluster is small.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-12-22 15:15:50 -0600

Seen: 752 times

Last updated: Jan 13 '15