Ask Your Question

RDO Juno, Neutron, CentOS 7: external router port DOWN

asked 2014-12-22 05:19:09 -0600

gerret gravatar image

updated 2014-12-22 12:59:22 -0600

Hi all,

I have installed RDO all-in-one on a CentOS 7 (VirtualBox VM hostname "rhino.stack"). I have been able to create cirros instances, assign floating IPs to the instances, and connect to them from the all-in-one host rhino.stack. I can access the public net just fine from the all-in-one host rhino.stack.

My problem is that I cannot connect from the instances to the public net. I have traced this to a connection problem between my OVS router and the external bridge "br-ex": The external port on the router reports being "DOWN". I also notice that no TAP device has been created for the the external bridge when I set the gateway for my router. I believe this is the underlying problem. Can anybody help me debug this setup and find out, why the TAP device does not get created?

I have two NICs on the all-in-one host: enp0s3 is a NAT interface provided by VirtualBox (IP GW, for accessing the public net) and enp0s8 is an access-interface (IP, so that I can ssh from my laptop to to rhino.stack VirtuanBox VM).

This is my configuration:

Interface setup

  [root@rhino ~(keystone_admin)]# cat /etc/sysconfig/network-scripts/ifcfg-br-ex
[root@rhino ~(keystone_admin)]# cat /etc/sysconfig/network-scripts/ifcfg-enp0s3
# ifcfg-enp0s3

"ovs-vsctl show" OVS and ifconfig

[root@rhino ~(keystone_admin)]# ovs-vsctl show
    Bridge br-int
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    Bridge br-tun
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
    Bridge br-ex
        Port "enp0s3"
            Interface "enp0s3"
        Port br-ex
            Interface br-ex
                type: internal
        Port "qg-d392c190-3f"
            Interface "qg-d392c190-3f"
                type: internal
    ovs_version: "2.1.3"

[root@rhino ~(keystone_admin)]# ifconfig
br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::b058:50ff:fee4:814f  prefixlen 64  scopeid 0x20<link>
        ether 08:00:27:73:58:2b  txqueuelen 0  (Ethernet)
        RX packets 97  bytes 7894 (7.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 99  bytes 9044 (8.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

br-int: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::5001:3ff:fe00:b44d  prefixlen 64  scopeid 0x20<link>
        ether 52:01:03:00:b4:4d  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 648 (648.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp0s3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::a00:27ff ...
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-04-11 11:18:26 -0600

rbowen gravatar image

This refers to an end-of-lifed version. If you're still experiencing the problem with a more recent version, please re-open. Thanks.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-12-22 05:19:09 -0600

Seen: 867 times

Last updated: Apr 11 '16