Error when starting compute: ip link add link eth1 name vlanNone type vlan id None Stderr: 'Error: argument "None" is wrong: id is invalid\n'

asked 2013-04-27 02:06:16 -0500

skyrainman gravatar image

Hello,

compute was running fine, then I enabled vlan networking and created a vlan, then compute would not start up. Even after I reverted the config, compute would still not start up. The complete error is given below.

I think it is trying to set the vlan on eth1 but the vlan id is blank. I am not sure where to set this or what to set but any help would be appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-05-08 04:50:36 -0500

thunderalien gravatar image

updated 2013-05-08 04:52:39 -0500

Hi,

I came across this error today, I changed to vlan mode as well. I solved it later by removing a previous network created without vlan, hence the error 'vlan none'. Then I used another new network with VLAN tag and start compute successfully!

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-27 02:06:16 -0500

Seen: 221 times

Last updated: May 08 '13