Error communicating when glance image create

asked 2014-12-20 01:50:22 -0500

vidhyasagar gravatar image

root@controller:/home/sathya# glance image-create --name "cirros-0.3.2-x86_64" --disk-format qcow2 --container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img Error communicating with http://192.168.1.11:9292 [Errno 111] Connection refused

edit retag flag offensive close merge delete

Comments

There could be multiple reasons behind this: confirm that your Glance service host's IP is 192.168.1.11 & glance API service is running on 9292 port. From the host which is trying to create image, check if you can connect to glance host. Check the firewall on the Glance host is not blocking traffic.

unmesh-gurjar gravatar imageunmesh-gurjar ( 2014-12-22 05:31:58 -0500 )edit

thank u, glance registry service port 9191 is binded.But glance api port is not binded . Even i created the proper endpoints for glance and keystone,mentioned the port numbers in the glanceapi.conf. netstat shows ports 9191 listening so glance services seem to be running, not showing 9292 port

vidhyasagar gravatar imagevidhyasagar ( 2014-12-22 06:31:04 -0500 )edit

i have disabled the firewall on startup

vidhyasagar gravatar imagevidhyasagar ( 2014-12-22 06:31:53 -0500 )edit

I suspect that the glance api service is down. Can you confirm that it is running? You might also want to give the glance api service logs a look to see for any start-up/related issues.

unmesh-gurjar gravatar imageunmesh-gurjar ( 2014-12-24 02:07:23 -0500 )edit

Restart the glance services and check the log files.Try to give log files details here.

Varsha gravatar imageVarsha ( 2015-01-14 10:21:16 -0500 )edit