Ask Your Question
0

2 node openstack installation using neutron OVS Vxlan

asked 2014-12-18 00:09:33 -0500

anonymous user

Anonymous

Hi

I am facing problem Openstack installation working with Neutron OVS Vxlan.

I need clear instructions to create a 2 node Openstack Installation (one controller + compute + neutron, and the other compute node). I preformed steps mentioned in the below link: https://openstack.redhat.com/Adding_a_compute_node (https://openstack.redhat.com/Adding_a...) .

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-18 00:34:28 -0500

dbaxps gravatar image

updated 2014-12-19 05:40:31 -0500

View : http://bderzhavets.blogspot.com/2014/...
Update answer-file :-

CONFIG_CONTROLLER_HOST=192.168.1.127
CONFIG_COMPUTE_HOSTS=192.168.1.137,192.168.1.127
CONFIG_NETWORK_HOSTS=192.168.1.127

and ignore Gluster Cluster setup && multiple cinder backends configurations.
Just run once on Controller Node :-

packstack --answer-file=./provided-answer-file.txt

Samples requested :-

[root@juno1 network-scripts(keystone_admin)]# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="192.168.1.127"
NETMASK="255.255.255.0"
DNS1="83.221.202.254"
BROADCAST="192.168.1.255"
GATEWAY="192.168.1.1"
NM_CONTROLLED="no"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no
ONBOOT="yes"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"

=====================

[root@juno1 network-scripts(keystone_admin)]# cat ifcfg-enp2s0
DEVICE="enp2s0"
# HWADDR=00:22:15:63:E4:E2
ONBOOT="yes"
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex
NM_CONTROLLED=no
IPV6INIT=no
edit flag offensive delete link more

Comments

I tried above steps but i am facing below error: ERROR : Error appeared during Puppet run: 104.156.59.53_neutron.pp Error: Could not start Service[neutron-ovs-agent-service]: Execution of '/usr/bin/systemctl start neutron-openvswitch-agent' returned 6: Failed to issue method call: Unit neutron-openv

Sainath Reddy gravatar imageSainath Reddy ( 2014-12-18 00:45:04 -0500 )edit

Install manually:

yum install openvswitch openstack-neutron-openvswitch

run again

packstack --answer-file=./provided-answer-file.txt
dbaxps gravatar imagedbaxps ( 2014-12-18 00:49:26 -0500 )edit

I just reinstalled OS and did above steps its worked.

but now i am not able to edit br-ex file with eno1. please let me know the steps to add br-ex and network communication.

Sainath Reddy gravatar imageSainath Reddy ( 2014-12-19 05:23:10 -0500 )edit

Replace enp2s0 by eno1:-

ifcfg-eno1
DEVICE=eno1
dbaxps gravatar imagedbaxps ( 2014-12-19 05:42:30 -0500 )edit

Next

chkconfig network on
service network restart
systemctl stop NetworkManager
systemctl disable NetworkManager
dbaxps gravatar imagedbaxps ( 2014-12-19 05:44:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-18 00:09:33 -0500

Seen: 574 times

Last updated: Dec 19 '14