Ask Your Question
0

Failed In Populating the db in Neutron

asked 2014-12-17 04:50:36 -0500

stevew gravatar image

updated 2014-12-17 19:44:42 -0500

smaffulli gravatar image

hi, I follow the installation guide for juno, and I get problem when I do the step below link text

I execute this code su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron. conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade juno" neutron.

and get errors below:

   > Traceback (most recent call last):
      File "/usr/bin/neutron-db-manage", line 10, in <module>
        sys.exit(main())
      File "/usr/lib/python2.7/dist-packages/neutron/db/migration/cli.py", line 171, in main
        CONF()
      File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 1681, in __call__
        else sys.argv[1:])
      File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 2227, in _parse_cli_opts
        return self._parse_config_files()
      File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 2243, in _parse_config_files
        self._oparser.parse_args(self._args, namespace)
      File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 1541, in parse_args
        return super(_CachedArgumentParser, self).parse_args(args, namespace)
      File "/usr/lib/python2.7/argparse.py", line 1690, in parse_args
        args, argv = self.parse_known_args(args, namespace)
      File "/usr/lib/python2.7/argparse.py", line 1722, in parse_known_args
        namespace, args = self._parse_known_args(args, namespace)
      File "/usr/lib/python2.7/argparse.py", line 1928, in _parse_known_args
        start_index = consume_optional(start_index)
      File "/usr/lib/python2.7/argparse.py", line 1868, in consume_optional
        take_action(action, args, option_string)
      File "/usr/lib/python2.7/argparse.py", line 1796, in take_action
        action(self, namespace, argument_values, option_string)
      File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 1100, in __call__
        ConfigParser._parse_file(values, namespace)
      File "/usr/lib/python2.7/dist-packages/oslo/config/cfg.py", line 1303, in _parse_file
        raise ConfigFileParseError(pe.filename, str(pe))
    oslo.config.cfg.ConfigFileParseError: Failed to parse /etc/neutron/plugins/ml2/ml2_conf.ini: at /etc/neutron/plugins/ml2/ml2_conf.ini:71, No ':' or '=' found in assignment: 'OVSHybridIptablesFirewallDriver'

I am grateful if anyone could help. Thank you !

My /etc/neutron/plugins/ml2/ml2_conf.ini.

[ml2]
type_drivers = flat,gre
tenant_network_types = gre
mechanism_drivers = openvswitch
# (ListOpt) List of network type driver entrypoints to be loaded from
# the neutron.ml2.type_drivers namespace.
#
# type_drivers = local,flat,vlan,gre,vxlan
# Example: type_drivers = flat,vlan,gre,vxlan

# (ListOpt) Ordered list of network_types to allocate as tenant
# networks. The default value 'local' is useful for single-box testing
# but provides no connectivity between hosts.
#
# tenant_network_types = local
# Example: tenant_network_types = vlan,gre,vxlan

# (ListOpt) Ordered list of networking mechanism driver entrypoints
# to be loaded from the neutron.ml2.mechanism_drivers namespace.
# mechanism_drivers =
# Example: mechanism_drivers = openvswitch,mlnx
# Example: mechanism_drivers = arista
# Example: mechanism_drivers = cisco,logger
# Example: mechanism_drivers = openvswitch,brocade
# Example: mechanism_drivers = linuxbridge,brocade

# (ListOpt) Ordered list of extension driver entrypoints
# to be loaded from the neutron.ml2.extension_drivers namespace.
# extension_drivers =
# Example: extension_drivers = anewextensiondriver

[ml2_type_flat]
# (ListOpt) List of physical_network names with which flat networks
# can be created. Use * to allow flat networks with arbitrary
# physical_network names.
#
# flat_networks =
# Example:flat_networks = physnet1,physnet2
# Example:flat_networks = *

[ml2_type_vlan]
# (ListOpt) List of <physical_network>[:<vlan_min>:<vlan_max>] tuples
# specifying physical_network names usable for VLAN provider and
# tenant networks, as well as ranges of VLAN tags on each
# physical_network available ...
(more)
edit retag flag offensive close merge delete

Comments

1

Could you post /etc/neutron/plugins/ml2/ml2_conf.ini

dbaxps gravatar imagedbaxps ( 2014-12-17 09:47:23 -0500 )edit

hi dbaxps, I have added the /etc/neutron/plugins/ml2/ml2_conf.ini below the errors. Please look at it Thanks

stevew gravatar imagestevew ( 2014-12-17 19:31:04 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-12-17 19:47:47 -0500

smaffulli gravatar image

Looks like there is a typo in your ini file. Check OVSHybridIptablesFirewallDriver should be a full line:

firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
edit flag offensive delete link more

Comments

Fixed it! Thank you very much!

stevew gravatar imagestevew ( 2014-12-17 20:34:56 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-17 04:50:36 -0500

Seen: 1,068 times

Last updated: Dec 17 '14