Ask Your Question
0

Unable to complete install: 'unsupported flags (0x1) in function virNetDevMacVLanCreateWithVPortProfile

asked 2014-12-16 09:11:55 -0600

I receive error

Unable to complete install: 'unsupported flags (0x1) in function virNetDevMacVLanCreateWithVPortProfile'

that likely related to bug version 1.2.9

root@compute11:~# libvirtd --version
libvirtd (libvirt) 1.2.9

if I install 1.2.10 version from tarball macvtap devices disappeared in virt-manager

Please help.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-13 21:05:02 -0600

updated 2015-01-13 21:05:55 -0600

I hava to answser myself.... but still want to know more about it.

Why repository has version 1.2.9 with bug and nobody cares to fix it in a two weeks?

Follow article https://www.redhat.com/archives/libvi...

I replaced VIR_CONNECT_RO flag with 0, and after I recompiled and rebuilt libvirtd 1.2.9 bug disappered.

However in source code for 1.2.10 this is not fixed, so likely they fixed it different.

Rebuilding libvirtd takes some time. http://libvirt.org/sources/ tar xvzf libvirt-1.2.9 cd libvir*

apt-get install libyajl-dev

apt-get install libxml2-dev

apt-get install libdevmapper-dev

apt-get install libnl-dev

apt-get install libgnutls-dev

vim /opt/libvirtlibvirt-1.2.9/src/phyp/phyp_driver.c

./configure --prefix=/usr

make;make install

service libvirtd restart

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-16 09:11:55 -0600

Seen: 275 times

Last updated: Jan 13 '15