Ask Your Question
0

'Keystone fail to get token' error while stacking using devstack

asked 2014-12-15 10:50:01 -0600

Sharad M gravatar image

On Fedora 20 using stable juno, I get the following error while running stack.sh with latest devstack on controller node -

  • echo 'Waiting for g-api (10.11.xx.yy:9292) to start...' Waiting for g-api (10.11.xx.yy:9292) to start...
  • wait_for_service 60 http://10.11.xx.yy:9292
  • local timeout=60
  • local url=http://10.11.xx.yy:9292
  • timeout 60 sh -c 'while ! curl -k --noproxy '\''*'\'' -s http://10.11.xx.yy:9292 >/dev/null; do sleep 1; done'
  • is_service_enabled g-reg ++ set +o ++ grep xtrace
  • local 'xtrace=set -o xtrace'
  • set +o xtrace
  • return 0 ++ keystone token-get ++ grep ' id ' ++ get_field 2 ++ local data field ++ read data Could not find user: admin (Disable debug mode to suppress these details.) (HTTP 401)
  • TOKEN=
  • die_if_not_set 1179 TOKEN 'Keystone fail to get token'
  • local exitcode=0 ++ set +o ++ grep xtrace
  • local 'xtrace=set -o xtrace'
  • set +o xtrace [Call Trace] ./stack.sh:1179:die_if_not_set /home/stack/devstack/functions-common:251:die [ERROR] /home/stack/devstack/functions-common:1179 Keystone fail to get token Error on exit World dumping... see ./worlddump-2014-12-15-163422.txt for details
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-15 11:36:41 -0600

Sharad M gravatar image

Resolved

Had to remove devstack folder. uninstall mariaDB packages and recloned devstack and all worked well.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-15 10:50:01 -0600

Seen: 899 times

Last updated: Dec 15 '14