Ask Your Question
0

Glance does not accept authentication

asked 2014-12-15 10:08:06 -0500

vari gravatar image

updated 2014-12-16 01:51:03 -0500

Hello, My current problem is that I installed glance (no error during the installation) and at the point I want to verify the installation with an image creation, I get the following error:

root@borkum:/tmp/images# source ~/admin-openrc.sh
root@borkum:/tmp/images# glance image-create --name "cirrosTestImage" --disk-format qcow2 \
--container-format bare --is-public True --progress < cirros-0.3.2-x86_64-disk.img
[=============================>] 100%
Request returned failure status.
HTTPInternalServerError (HTTP 500)

my admin-openrc settings are exactly as described in the installation guide . Has anybody an idea, what I could do? I already tryed diefferend authentication settings, but non of them worked.

Edit:

The /var/log/glance/registry.og file gives this:

OperationalError: (OperationalError) (1045, "Access denied for user 'glance'@'controller' (using password: YES)") None None
2014-12-16 10:37:49.800 26102 INFO glance.wsgi.server [KEYSTONE IDs - - -] 127.0.0.1 - - [16/Dec/2014 10:37:49] "POST /images HTTP/1.1" 500 139 0.516276

The api.log says nothing more. The debug output isn't very helpfull either. I also checked that the user glance is in the admin role and in the glance tenant.

edit retag flag offensive close merge delete

Comments

Check your glance log at /var/log/glance and put the error message on your post.

Mzoorikh gravatar imageMzoorikh ( 2014-12-15 10:32:42 -0500 )edit

I meet the same problem, have you fixed it yet?

darren-wang gravatar imagedarren-wang ( 2015-01-11 22:43:11 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-12-16 02:58:51 -0500

Drop the glance database and set the character set to utf8 mysql -u root -p

CREATE DATABASE glance DEFAULT CHARACTER SET utf8;

edit flag offensive delete link more

Comments

Still won't work.

vari gravatar imagevari ( 2014-12-16 03:38:19 -0500 )edit
0

answered 2014-12-15 10:23:21 -0500

Anorak gravatar image

You should take a look in the glance logs if you haven't already. Set debug = True as well in the glance conf files to extract the detailed info on what's going on in the back ground.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-15 10:08:06 -0500

Seen: 635 times

Last updated: Dec 16 '14