Ask Your Question
0

determining ip information for eth0...

asked 2014-12-13 22:36:41 -0500

cn gravatar image

updated 2014-12-30 18:58:39 -0500

smaffulli gravatar image

when launching a new vm it hangs at the below line.

 Determining IP information for eth0...

Searching the forum found similar question but did not help address my issue.

Initially i started with all-in-node , everything was working fine, i mean when i launched VM it was working. Then i added a compute node , even now if i launch the VM in the same node i.e. the all-in-one node it is working fine. But if the VM is launched in the compute node that is in separate ucs box then the VM hangs at the above line.

I do not understand why 2 instance of dnsmasq is running.

Hope the below information might be needed to identify my problem

**ps -ef | grep dnsmasq**


  libvirt+  4221     1  0 Nov18 ?        00:00:08 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf

  nobody    5496     1  0 Nov18 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --  interface=tap4c8cddb7-12 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/33181455-c89e-4fc9-a952-ea69501c9aed/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/33181455-c89e-4fc9-a952-ea69501c9aed/host --addn-hosts=/var/lib/neutron/dhcp/33181455-c89e-4fc9-a952-ea69501c9aed/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/33181455-c89e-4fc9-a952-ea69501c9aed/opts --leasefile-ro --dhcp-range=set:tag0,10.10.10.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

  nobody    5498     1  0 Nov18 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapa3bbe5ed-66 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/0a3151c8-e1c2-4e4d-ade0-025c1f06ad46/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/0a3151c8-e1c2-4e4d-ade0-025c1f06ad46/host --addn-hosts=/var/lib/neutron/dhcp/0a3151c8-e1c2-4e4d-ade0-025c1f06ad46/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/0a3151c8-e1c2-4e4d-ade0-025c1f06ad46/opts --leasefile-ro --dhcp-range=set:tag0,10.86.146.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal
  root     10800  5795  0 13:50 pts/1    00:00:00 grep --color=auto dnsmasq

ovs-vsctl show

710dd402-bc77-410c-ab52-f75a10a1a175
Bridge br-tun
    Port br-tun
        Interface br-tun
            type: internal
Bridge br-int
    Port "qr-2dd2c0ea-1e"
        tag: 1
        Interface "qr-2dd2c0ea-1e"
            type: internal
    Port br-int
        Interface br-int
            type: internal
    Port "tap4c8cddb7-12"
        tag: 1
        Interface "tap4c8cddb7-12"
            type: internal
    Port "qvo31d65786-98"
        tag: 1
        Interface "qvo31d65786-98"
    Port "qvo83b631f7-2f"
        tag: 1
        Interface "qvo83b631f7-2f"
    Port "tapa3bbe5ed-66"
        tag: 2
        Interface "tapa3bbe5ed-66"
            type: internal
Bridge br-ex
    Port "eth1"
        Interface "eth1"
    Port br-ex
        Interface br-ex
            type: internal
    Port "qg-c40bdf74-2e"
        Interface "qg-c40bdf74-2e"
            type: internal
ovs_version: "2.0.2"

cat /var/lib/libvirt/dnsmasq/default.conf

 ##WARNING:  THIS IS AN AUTO-GENERATED FILE. CHANGES TO IT ARE LIKELY TO BE
 ##OVERWRITTEN AND LOST.  Changes to this configuration should be made using:
 ##    virsh net-edit default
 ## or other application using the libvirt API.
 ##
 ## dnsmasq conf file created by libvirt
strict-order
user=libvirt-dnsmasq
pid-file=/var/run/libvirt/network/default.pid
except-interface=lo
bind-dynamic
interface=virbr0
dhcp-range=192.168.122.2,192.168.122.254
dhcp-no-override
dhcp-leasefile=/var/lib/libvirt/dnsmasq/default.leases
dhcp-lease-max=253
dhcp-hostsfile=/var/lib/libvirt/dnsmasq/default.hostsfile
addn-hosts=/var/lib/libvirt/dnsmasq/default.addnhosts

* ip addr *

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever ...
(more)
edit retag flag offensive close merge delete

Comments

How did you set up Compute Node ?

dbaxps gravatar imagedbaxps ( 2014-12-30 23:27:25 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-04 20:03:22 -0500

Are you using GRE tunnels between management node and additional compute node?

ovs-vsctl show does not show any tunnels so either GRE is not in use or it is not configured correctly.

The fact that the all in one node works and the additional compute node does not work tells me that the management node (all in one) does not seem to know about the new compute node.

What does the following output show you from the management node (all in one):

nova service-list neutron agent-list

Do you see the additional compute node in the output of the two items above and does it indicate it is up?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-12-13 22:36:41 -0500

Seen: 691 times

Last updated: Jan 04 '15