Ask Your Question
0

Cannot ping to external gateway (juno version)

asked 2014-12-13 12:50:01 -0600

Tung Nguyen gravatar image

Hi All,

I was build openstack juno follow official document with 3 node and i have problem with netwoking that i cannot ping to external router's gateway from external network, also i cannot ping to external network's gateway from router.

The problem in log when i add gateway for router - Controller node /var/log/neutron/server.log

2014-12-12 16:40:54.389 6657 WARNING neutron.plugins.ml2.managers [req-d2035fa4-0fab-4dbf-8cc9-914f3b1b26b0 None] Failed to bind port 7dfa1779-39b8-42c6-8d74-83ae87ef15b1 on host network
2014-12-12 16:40:54.413 6657 WARNING neutron.plugins.ml2.plugin [req-d2035fa4-0fab-4dbf-8cc9-914f3b1b26b0 None] In _notify_port_updated(), no bound segment for port 7dfa1779-39b8-42c6-8d74-83ae87ef15b1 on network 36b485bb-28cb-437b-9c3e-2aebbf6796cb
  • Network node /var/log/openvswitch/ovs-vswitchd.log:

2014-12-12T08:31:48.169Z|00038|bridge|INFO|bridge br-ex: added interface qg-ae634c48-5b on port 4 2014-12-12T08:31:48.365Z|00039|netdev_linux|INFO|ioctl(SIOCGIFHWADDR) on qg-ae634c48-5b device failed: No such device 2014-12-12T08:31:49.255Z|00040|netdev_linux|WARN|ioctl(SIOCGIFINDEX) on qg-ae634c48-5b device failed: No such device

[root@network ~]# ovs-vsctl show
5823161d-12cd-491f-b2b8-36c39f35fde2
Bridge br-int
  fail_mode: secure
  Port patch-tun
      Interface patch-tun
          type: patch
          options: {peer=patch-int}
  Port "qr-c3a9db35-93"
      tag: 1
      Interface "qr-c3a9db35-93"
          type: internal
  Port "tape3afe5a5-42"
      tag: 4095
      Interface "tape3afe5a5-42"
          type: internal
  Port "tap431d2430-68"
      tag: 1
      Interface "tap431d2430-68"
          type: internal
  Port br-int
      Interface br-int
          type: internal
  Port int-br-ex
      Interface int-br-ex
          type: patch
          options: {peer=phy-br-ex}
Bridge br-ex
  Port br-ex
      Interface br-ex
          type: internal
  Port "qg-f01f08b5-ae"
      Interface "qg-f01f08b5-ae"
          type: internal
  Port phy-br-ex
      Interface phy-br-ex
          type: patch
          options: {peer=int-br-ex}
  Port "eth2"
      Interface "eth2"
Bridge br-tun
  Port br-tun
      Interface br-tun
          type: internal
  Port "gre-0a0a0b1f"
      Interface "gre-0a0a0b1f"
          type: gre
          options: {df_default="true", in_key=flow, local_ip="10.10.11.21",

out_key=flow, remote_ip="10.10.11.31"} Port patch-int Interface patch-int type: patch options: {peer=patch-tun} ovs_version: "2.1.3"

[root@network ~]# ovs-ofctl show br-ex
OFPT_FEATURES_REPLY (xid=0x2): dpid:0000005056964220
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP
actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 1(eth2): addr:00:50:56:96:42:20
     config:     0
     state:      0
     current:    1GB-FD COPPER AUTO_NEG
     advertised: 10MB-HD 10MB-FD 100MB-HD 100MB-FD 1GB-FD COPPER AUTO_NEG
     supported:  10MB-HD 10MB-FD 100MB-HD 100MB-FD 1GB-FD COPPER AUTO_NEG
     speed: 1000 Mbps now, 1000 Mbps max
 3(phy-br-ex): addr:66:38:3c:8f:9f:53
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 5(qg-f01f08b5-ae): addr:00:50:56:96:42:20
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
 LOCAL(br-ex): addr:00:50:56:96:42:20
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0

Can you help me ? Thanks,

edit retag flag offensive close merge delete

Comments

search this site for 'cannot ping' and you'll find a lot of suggestions on how to proceed debugging this issue. Keep editing the question as you go on debugging.

smaffulli gravatar imagesmaffulli ( 2014-12-13 14:04:05 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-13 17:48:47 -0600

Tung Nguyen gravatar image

Issue have been resolved. Problem is ESXi using test lab doesn't enable promiscuous mode.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-13 12:50:01 -0600

Seen: 540 times

Last updated: Dec 13 '14