Ask Your Question
0

can't open console to a new instance (juno)

asked 2014-12-12 05:31:11 -0500

Glen.GZ gravatar image

followlling the juno instruction, i was about to set up a new instance via cli on controller. when i came to a step of obtaining a VNC URL of my instance, it returned to me that URL starting from http://COMPUTE_IP_ADD:6080.. . should it here be a http://CONTROLLER_IP_ADD:6080... . instead? i'm confused, coz apache only installs on controller. and i failed to open this URL, only showed a grey backgroup with "connection timeout" on it.

i logged into webui, checking the log of this instance, like below. where does it go wrong?

failed to get instance-id of datasource Starting dropbear sshd: OK === system information === Platform: OpenStack Foundation OpenStack Nova Container: none Arch: x86_64 CPU(s): 1 @ 2393.984 MHz Cores/Sockets/Threads: 1/1/1 Virt-type: VT-x RAM Size: 491MB Disks: NAME MAJ:MIN SIZE LABEL MOUNTPOINT vda 253:0 1073741824
vda1 253:1 1061061120 cirros-rootfs / === sshd host keys === -----BEGIN SSH HOST KEY KEYS----- ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAAAgmtA4AnrLuG6+6BrB8tim/fezPv7Hpt2FmgtJa87k11Knw6u4n/WT4ZlQ51tmMXrMesHwt5TQxukZAGZll4i6hXxY5daFEZw2JUth6eAfwuxkRvzedgtgiYp6JoN9thyXCssnwipCyTG+zWmcIqxeAEfNT5EZQbFF813dUiCGXJUzzk= root@cirros ssh-dss AAAAB3NzaC1kc3MAAACBAK6OaY2wy2KRlxU5LkPMvW4ovztZFa8i1D/YnHtDbJZjCY3SA9J2hVyHcvdrGpjbf1021AE73RCbHC5YJZfw8IeyJbdTJt23iJTAcYHy2dPmIyANZqMfzZWKj+joz8nMQAz+TiQWlTAbsXU/wa81dI0jyz3eGjje88bN+GuYa44ZAAAAFQDasAkK1s6Xo3ryc+OgGMD92+FbQQAAAIBLoOzPlJRNv9H0NFA71c35uPTR9LvrA/qmqCeu1ZzQXLzlBccC7EPiHZoZlJG/X3px/Cl2bqooAxFxy/ZBQsrvPHNqLVt1ws6iMfpS/P/BOffoE03GWIqFKkNDF5GuJHklOv/1dVD/2GnvjmMJwudZhiQOMHFAg9Mj0ryPI0PIiQAAAIBDpXKC8bzno/VghlD5yzMI/8QmLcTa/BhqLbf2OcEi7UHTNnRqjqn/B0hPnZjeVTL9Ifx1HMfS2LUpfdeL2BO6j7JuewLjyTDDwjDlgfBo5OhiFLENiJZaVoWSDL3+kEbkVTvJk/BzFN3UHvILywr2E9LMQJwRQ7HOtzWTaTeNHg== root@cirros -----END SSH HOST KEY KEYS----- === network info === if-info: lo,up,127.0.0.1,8,::1 if-info: eth0,up,192.168.1.4,24,fe80::f816:3eff:fed1:7b42 ip-route:default via 192.168.1.1 dev eth0 ip-route:192.168.1.0/24 dev eth0 src 192.168.1.4 === datasource: None None === === cirros: current=0.3.3 uptime=41.86 === ____ ____ ____ / __/ __ ____ ____ / __ \/ __/ / /__ / // __// __// /_/ /\ \ ___//_//_/ /_/ ____/___/ http://cirros-cloud.net

login as 'cirros' user. default password: 'cubswin:)'. use 'sudo' for root. cirros login:

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-12 05:37:51 -0500

Check your nova.conf on your compute node. It should contains something like:

vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = compute_ip
novncproxy_base_url = http://controller_ip:6080/vnc_auto.html

You could find additional info on official guide

edit flag offensive delete link more

Comments

I am trying be helpful and say:

1) you can get some text log with

nova console-log "instance"

2)

Grey screen with VNC often means

~/.vnc/xstartup

is invalid.

If only you get any screen at all.

szemtsov gravatar imageszemtsov ( 2014-12-12 06:32:10 -0500 )edit

thanks, Antonio! it works

Glen.GZ gravatar imageGlen.GZ ( 2014-12-15 00:49:20 -0500 )edit

I have done the setting in nova.conf still vnc does not work.

lsof -i:5900

on compute node does not return anything. How to enable vnc to listen on port 5900?

fresher gravatar imagefresher ( 2014-12-30 05:04:55 -0500 )edit

Have you restarted nova related services? 5900 is the standard port vnc is working on, if you spawn more than one VM, then you should see compute node listening on following ports too (5901,5902,etc...)

Antonio G. gravatar imageAntonio G. ( 2014-12-30 05:29:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-12-12 05:31:11 -0500

Seen: 1,598 times

Last updated: Dec 12 '14