Ask Your Question
0

All nova service list are in "down" state and there is no "nova-compute" service

asked 2014-12-10 03:16:51 -0500

AlonFre gravatar image

updated 2015-03-09 12:32:18 -0500

bishoy gravatar image

we are installling the the openStack system accorsding to this guide: http://docs.openstack.org/juno/instal... we are in chapter 5 now, configuring the compute node. when verifying the the Nova service-list, we can see that all services are down and there is no service: nova-compute.

-there is a ping communication between the controller and the compute stations, but, the NTP in the controller does not get synchronized (we dont know if this problam is related...)

nova service-list

+----+------------------+---------------+----------+---------+-------+------------+-----------------+
| Id | Binary           | Host          | Zone     | Status  | State | Updated_at | Disabled Reason |
+----+------------------+---------------+----------+---------+-------+------------+-----------------+
| 1  | nova-cert        | ubuntuServer2 | internal | enabled | down  | -          | -               |
| 2  | nova-consoleauth | ubuntuServer2 | internal | enabled | down  | -          | -               |
| 3  | nova-scheduler   | ubuntuServer2 | internal | enabled | down  | -          | -               |
| 4  | nova-conductor   | ubuntuServer2 | internal | enabled | down  | -          | -               |
+----+------------------+---------------+----------+---------+-------+------------+-----------------+

Thanks in advance, Alon

edit retag flag offensive close merge delete

Comments

1

What says /var/log/nova/nova-compute.log ?

dbaxps gravatar imagedbaxps ( 2014-12-10 03:38:03 -0500 )edit

the nova-compute los says:

2014-12-10 11:57:29.642 13495 INFO oslo.messaging._drivers.impl_rabbit [req-c2580ed8-b35e-44e8-aba0-5e8b447a42d3 ] Delaying reconnect for 1.0 seconds... 2014-12-10 11:57:30.643 13495 INFO oslo.messaging._drivers.impl_rabbit [req-c2580ed8-b35e-44e8-aba0-5e8b447a42d3 ] Con

AlonFre gravatar imageAlonFre ( 2014-12-10 04:00:16 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2014-12-10 04:01:36 -0500

AlonFre gravatar image

the nova compute says:

2014-12-10 11:57:29.642 13495 INFO oslo.messaging._drivers.impl_rabbit [req-c2580ed8-b35e-44e8-aba0-5e8b447a42d3 ] Delaying reconnect for 1.0 seconds... 2014-12-10 11:57:30.643 13495 INFO oslo.messaging._drivers.impl_rabbit [req-c2580ed8-b35e-44e8-aba0-5e8b447a42d3 ] Connecting to AMQP server on controller:5672 2014-12-10 11:57:35.655 13495 ERROR oslo.messaging._drivers.impl_rabbit [req-c2580ed8-b35e-44e8-aba0-5e8b447a42d3 ] AMQP server on controller:5672 is unreachable: timed out. Trying again in 29 seconds.

edit flag offensive delete link more

Comments

and on the controller we can see that this port is on "listen" mode: root@ubuntuServer2:~# netstat -anltp|grep :5672 tcp6 0 0 :::5672 :::* LISTEN 17799/beam.smp

AlonFre gravatar imageAlonFre ( 2014-12-10 04:05:15 -0500 )edit
1
dbaxps gravatar imagedbaxps ( 2014-12-10 04:12:50 -0500 )edit

Thank you all very much! we found the problem and now everything is runing o.k! the mapping between hosts name and ip addresses was wrong in the etc/hosts..

AlonFre gravatar imageAlonFre ( 2014-12-10 05:04:58 -0500 )edit
1

AloneFre, you are correct, even if the rabbit is not working it doesn't mean that the nova services show down state as it don't use the rabbit to communicate between each other in the first place, Rabbit is used among openstack projects but nova service-list is an api call.

bishoy gravatar imagebishoy ( 2014-12-10 09:08:10 -0500 )edit

hello will you please tell me what was wrong in the /etc/hosts file which mapping was wrong? I'm facing the exact same error.

Pauravi gravatar imagePauravi ( 2015-03-13 08:26:31 -0500 )edit
1

answered 2015-04-16 22:53:23 -0500

Richard Hong gravatar image

I have the same issue, and after reset RabbitMQ password, it works. But I can only get 4 service item, the nova-compute is not in list.

| 1 | nova-consoleauth | controller | internal | enabled | up | 2015-04-17T03:07:34.000000 | - |

| 2 | nova-cert | controller | internal | enabled | up | 2015-04-17T03:07:34.000000 | - |

| 3 | nova-conductor | controller | internal | enabled | up | 2015-04-17T03:07:34.000000 | - |

| 4 | nova-scheduler | controller | internal | enabled | up | 2015-04-17T03:07:34.000000

edit flag offensive delete link more
1

answered 2015-06-16 06:50:35 -0500

Karan Chhabra gravatar image

updated 2015-06-16 06:51:59 -0500

I have the same issue. All the services on controller are down and i cant even see the nova-compute service.

edit flag offensive delete link more
0

answered 2015-09-15 14:35:16 -0500

If there is another solution I'm interested. I'm having the same issue but I can ping between the hosts using their hostname.

edit flag offensive delete link more

Comments

Is this issue resolved for you. Because I'm also facing the same issue. please Can any one suggest other solution for resolving this issue.

Harsha gravatar imageHarsha ( 2017-03-29 23:48:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-10 03:16:51 -0500

Seen: 14,233 times

Last updated: Jun 16 '15