Ask Your Question
0

use l2 population,vxlan can not establish tunnel

asked 2014-12-10 02:43:17 -0500

bitaoxiao gravatar image

updated 2014-12-10 02:44:34 -0500

When i set the l2 population true and add it into mechanism_drivers,then the ovs vxlan tunnel not be established.

The openstack version is 2014.2,juno

Below is my ml2_conf.ini

[ml2]

type_drivers = vxlan

tenant_network_types = vxlan

mechanism_drivers = openvswitch,l2population

[ml2_type_flat]

[ml2_type_vlan]

[ml2_type_gre]

tunnel_id_ranges = 2001:4000

[ml2_type_vxlan]

vni_ranges = 1:2000

[securitygroup]

firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

enable_security_group = True

[ovs]

local_ip = 10.0.30.100

tunnel_type = vxlan

tunnel_bridge = br-tun

integration_bridge = br-int

tunnel_id_ranges = 1:69999

tenant_network_type = vxlan

enable_tunneling = true

bridge_mappings = external:br-ex

[agent]

root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf

tunnel_types = vxlan

vxlan_udp_port = 4789

l2_population = True

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-10 02:56:48 -0500

dbaxps gravatar image
edit flag offensive delete link more

Comments

ovs in my env is 2.0.1,i will try the content in the post.

thanks a lot

bitaoxiao gravatar imagebitaoxiao ( 2014-12-10 03:12:53 -0500 )edit

Should be ML2 + OVS >= 2.1

dbaxps gravatar imagedbaxps ( 2014-12-10 03:27:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-10 02:43:17 -0500

Seen: 255 times

Last updated: Dec 10 '14