Ask Your Question
0

Devstack install failure: Tempest semantic version is 3.0.0

asked 2014-12-09 12:22:14 -0500

Gaya3 gravatar image

updated 2014-12-09 12:43:40 -0500

I have trusty 14.04 Ubuntu and installing devstack on it. ./stack.sh fails with the following error. Any pointers?

2014-12-08 23:39:37.798 | error in setup command: Error parsing /opt/stack/tempest/setup.cfg: ValueError: git history requires a target version of pbr.version.SemanticVersion(3.0.1), but target version is pbr.version.SemanticVersion(3.0.0)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-07-10 10:58:44 -0500

guangyu gravatar image

git fetch the latest tags should solve the problem.

edit flag offensive delete link more
0

answered 2014-12-09 15:03:01 -0500

Not familiar enough with Tempest to know why this is broken. However, to fix it:

Go to /opt/stack/tempest/setup.cfg and change the version under [metadata].

So mine was 'version = 3'. Change it to 'version = 3.0.1' and it should work fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-09 12:22:14 -0500

Seen: 881 times

Last updated: Dec 09 '14