Ask Your Question
0

auto_assign_floating_ip=True is failing VMs from starting

asked 2014-12-08 16:30:28 -0600

nitins gravatar image

HI,

I have Juno running on Ubuntu 14.04. I am able to start VMs fine on my setup, but after I added the "auto_assign_floating_ip=True" in nova.conf file , The VMs fail to spawn giving an error

line 772, in floating_ip_allocate_address\n raise exception.NoMoreFloatingIps()\n\nNoMoreFloatingIps: Zero floating ips available.\n\n']

But I made sure there are more than enough floating IPs available. Also if I remove this line from the nova.conf file and associate a floating ip after launching a VM , it works fine.

The auto assignment of floating IPs in not working. Any ideas how to make it work or this is bug.

Thanks for the help.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-08 16:42:17 -0600

mpetason gravatar image

You may have plenty of floating IP addresses however did you allocate extra to the tenant? It should look for available Floating IP addresses in your allocated pool then assign it afterwards. You need to manually allocate multiple Floating IP addresses from the pool.

Can you try allocating a bunch to your tenant and then launch an instance again? I'm not sure if there is additional work that needs to be configured for this or if it is a relic of nova-network.

edit flag offensive delete link more

Comments

I have already assigned 14 IPs to my tenant and that is why I can manually assign floating IPs to VMs.

Its the auto part that doesn't work.

nitins gravatar imagenitins ( 2014-12-08 17:40:14 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-08 16:30:28 -0600

Seen: 215 times

Last updated: Dec 08 '14