Instances spawned in tenants other than admin won't get IP address.

asked 2014-12-08 03:46:30 -0600

Veena gravatar image

In the Icehouse setup, when I spawn VM in different tenant other than Admin, the controller shows that IP is assigned to VM. But the VM interface will not have the IP assigned to it when checked from the console. There are no Error logs in nova and neutron. I guess in some config files some where I have specified admin url instead of public url. I'm unable to find that and solve. Can anybody please point me the cause for this problem. Thanks in advance for the help.



edit retag flag offensive close merge delete


Please, provide :-

neutron net-list
ip netns
ps -ef | grep dnsmasq

As UPDATE1 to question

dbaxps gravatar imagedbaxps ( 2014-12-08 04:56:57 -0600 )edit

Please find the output of the above commands in

Veena gravatar imageVeena ( 2014-12-08 06:21:50 -0600 )edit

Activate /var/log/neutron/dnsmasq.log. Add to dhcp_agent.ini :-

dnsmasq_config_file = /etc/neutron/dnsmasq.conf
dbaxps gravatar imagedbaxps ( 2014-12-08 06:30:52 -0600 )edit

Create under /etc/neutron :

$ cat  dnsmasq.conf
log-facility = /var/log/neutron/dnsmasq.log
dbaxps gravatar imagedbaxps ( 2014-12-08 06:31:50 -0600 )edit

I have the following configuration done in dhcp_agent.ini file as it was mentioned in the OpenStack Icehouse installation doc.

dnsmasq_config_file = /etc/neutron/dnsmasq-neutron.conf

and /etc/neutron/dnsmasq-neutron.conf has


should I have to change it as mentioned above?

Veena gravatar imageVeena ( 2014-12-08 22:12:33 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-12-08 13:59:37 -0600

mpetason gravatar image

You currently have one qrouter : qrouter-dcc0a0aa-f5cc-44b4-b5db-f94028c31915 and one dhcp space : qdhcp-0df1d4e7-b574-42c5-8261-03982fdd9b17 which means that you may not have configured the router or the networking correctly for the tenant.

When you setup a new network within a tenant you'll need to also setup the Router and attach it to the public network (set gateway) and then attach the subnet you created for the tenant to the Router (in Horizon you can click on the router and modify ports and what is connected to it.)

With this you should be launching off of the correct network:

| id                                   | name      | subnets                                             |
| 0df1d4e7-b574-42c5-8261-03982fdd9b17 | vm-net    | 0ffdeda3-f354-4549-bfcb-e5b1348bca7f |
| 4735a976-e0c3-423b-8047-ac720893e515 | ext-net   | 8a665fff-aca8-41d9-b5cc-c65b623b78bf  |
| 48dafbd2-3ece-42df-a645-1f273439bddb | net1      | 6b5c5843-0d98-414f-a6bc-f74f3dcf2679 |

I'm guessing vm-net is the network you may have just created since it is .1 instead of .0. If this is the case then you need to connect it to a router and set the gateway for the router then try to launch the instance.

You should never launch an instance on the External network (ext-net) when using Neutron + GRE/VLAN (Unless you have done custom configuration to make it possible.)

edit flag offensive delete link more


Hi, I have followed the same steps as you mentioned. vm-net is the network in admin tenant and net1 is the network in another tenant which is not added as a user of admin tenant. Bot have routers attached and the gateway is set to ext-net which is a shared network have floating-ip pool.

Veena gravatar imageVeena ( 2014-12-08 22:15:32 -0600 )edit

Is net1 connected to the router? Are you using the same images on the tenant as you were in the Admin tenant?

mpetason gravatar imagempetason ( 2014-12-09 09:01:11 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2014-12-08 03:46:30 -0600

Seen: 363 times

Last updated: Dec 08 '14